Exponentiation

Exponentiation

Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 93274 Accepted: 22295

Description

Problems involving the computation of exact values of  very large magnitude and precision are common. For example, the computation of  the national debt is a taxing experience for many computer systems.

This  problem requires that you write a program to compute the exact value of  R n where R is a real number ( 0.0 < R < 99.999 ) and n is an  integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for  R and n. The R value will occupy columns 1 through 6, and the n value will be in  columns 8 and 9.

Output

The output will consist of one line for each line of  input giving the exact value of R^n. Leading zeros should be suppressed in the  output. Insignificant trailing zeros must not be printed. Don't print the  decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
http://poj.org/problem?id=1001
这道题我是首先储存小数点的位置,把它变成大整数的高精度幂来做,然后再计算好小数点的位置,去掉前导的0,添加到结果中,最后再去掉小数点后多余的‘0’。
 
#include <cstdio>
#include <string>
using namespace std;

#define MAX 155

char cn[8],cresult[MAX];
int an1[MAX],an2[8],aresult[MAX],n,len1,len,i,fg,j,len2,z;

int chengfa(int *an1,int *an2,int &len1,int len2)
{
	int i,j;
	for (i=0;i<len2;i++)
		for (j=0;j<len1;j++)
			aresult[j+i]+=an1[j]*an2[i];
	for (i=0;i<MAX;i++)
	{
		if (aresult[i]>0)
		{
			aresult[i+1]+=aresult[i]/10;
			aresult[i]%=10;
			len1=i+1;
		}
		an1[i]=aresult[i];
	}
	return 0;
}

int main()
{
	while (scanf("%s%d",cn,&n)!=EOF)
	{
		len2=j=len1=strlen(cn);
		z=fg=0;
		i=0;
		bool jud=false;
		memset(an1,0,sizeof(an1));
		memset(an2,0,sizeof(an2));
		memset(aresult,0,sizeof(aresult));
		while (--j>=0)
		{
			if (cn[j]!='.')
			{
				an2[i]=an1[i]=cn[j]-'0';
				++i;
			}
			else
				z=fg=len1-j-1;
		}
		if (n==0)
		{
			printf("1\n");
			continue;
		}
		if (n==1)
		{
			j=len1;
			i=0;
			while (--j>=0)
			{
				aresult[i]=an1[i];
				++i;
			}
		}
		while (--n>0)
		{
			memset(aresult,0,sizeof(aresult));
			chengfa(an1,an2,len1,len2);
			fg+=z;
		}
		i=0;
		for (j=MAX-1;j>=fg;--j)
		{
			if (jud)
			{
				cresult[i++]=aresult[j]+'0';
			}
			else if (aresult[j]>0)
			{
				cresult[i++]=aresult[j]+'0';
				jud=true;
			}
		}
		cresult[i++]='.';
		for (j=fg-1;j>=0;j--)
		{
			cresult[i++]=aresult[j]+'0';
		}
		--i;
		for (j=0;j<=fg;j++)
			if (cresult[i--]!='0')
			{
				cresult[i+2]='\0';
				break;
			}
			if (cresult[0]=='.'&&cresult[1]=='\0')
				cresult[0]='0';
			else if (cresult[i+1]=='.'&&cresult[i+2]=='\0')
				cresult[i+1]='\0';
			printf("%s\n",cresult);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值