九度OJ - 1201 - 二叉排序树

题目描述

输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入

输入第一行包括一个整数n(1<=n<=100)。
接下来的一行包括n个整数。

输出

可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。

每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入

5
1 6 5 9 8

样例输出

1 6 5 9 8
1 5 6 8 9
5 8 9 6 1

提示

输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。

来源

2005年华中科技大学计算机保研机试真题


建树注意一下,很坑啊,静态数组会爆的 = =,

#include<cstdio>
#include<cstring>
#include<iostream>
#include<stdlib.h>
#include<algorithm>
#include<malloc.h>
using namespace std;

int n;
int num[105];

typedef struct Tree{
    int data;
    struct Tree *rchild, *lchild;
}BiTNode, *BiTree;

BiTree T1;

void createTree(BiTree &T, int i){
    if(i > n)
        return;

    if(T == NULL){
        T = (BiTNode *)malloc(sizeof(BiTNode));
        T->data = num[i];
        T->lchild = T->rchild = NULL;
    }
    else if(T->data > num[i]){
        createTree(T->lchild, i);
    }
    else if(T->data < num[i])
        createTree(T->rchild, i);

}

void build(BiTree &T){    //创建二叉排序树
    T = NULL;
    for(int i = 1; i <= n; i++)
        createTree(T, i);
}

void preOrderTree(BiTree &T){    //前序遍历
    if(T == NULL)
        return;
    cout << T->data << " ";
    preOrderTree(T->lchild);
    preOrderTree(T->rchild);
}

void inOrderTree(BiTree &T){    //中序遍历
    if(T == NULL)
        return;
    inOrderTree(T->lchild);
    cout << T->data << " ";
    inOrderTree(T->rchild);
}

void backOrderTree(BiTree &T){   //后序遍历
    if(T == NULL)
        return;
    backOrderTree(T->lchild);
    backOrderTree(T->rchild);
    cout << T->data << " ";
}

int main()
{
    while(scanf("%d", &n)!=EOF && n){
        for(int i = 1; i <= n; i++)
            cin >> num[i];

        T1 = NULL;
        build(T1);

        preOrderTree(T1);
        cout << endl;

        inOrderTree(T1);
        cout << endl;

        backOrderTree(T1);
        cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值