九度OJ - 1350 - 二叉树的深度

题目描述

输入一棵二叉树,求该树的深度。从根结点到叶结点依次经过的结点(含根、叶结点)形成树的一条路径,最长路径的长度为树的深度。

输入

第一行输入有n,n表示结点数,结点号从1到n。根结点为1。 n <= 10。
接下来有n行,每行有两个个整型a和b,表示第i个节点的左右孩子孩子。a为左孩子,b为右孩子。当a为-1时,没有左孩子。当b为-1时,没有右孩子。

输出

输出一个整型,表示树的深度。

样例输入

3
2 3
-1 -1
-1 -1

样例输出

2


#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

struct TreeNode{
    int lchild;
    int rchild;
};

TreeNode Tree[20];

int depthTree(int x, int n){
    if(x < 1 || x > n)
        return 0;
    if(Tree[x].lchild==-1 && Tree[x].rchild==-1){
        return 1;
    }
    int leftdepth = depthTree(Tree[x].lchild, n);
    int rightdepth = depthTree(Tree[x].rchild, n);
    return leftdepth >= rightdepth ? leftdepth+1 : rightdepth+1;
}

int main()
{
    int n, left, right, depth;
    while(scanf("%d", &n)!=EOF){
        for(int i = 1; i <= n; i++){
            cin >> left >> right;
            Tree[i].lchild = left;
            Tree[i].rchild = right;
        }

        int depth = depthTree(1, n);
        cout << depth << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值