PAT甲级A1112 Stucked Keyboard (20 分)

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

题意:给出一个整数k,再给一个字符串,假设键盘中某些键坏了,每次按坏的按键都会重复k次,让你找出这些迟滞键并输出正常的字符串。

注意:如果字符串中某个键曾经出现过正常状态,也出现过k次重复,则认为按键是正常的,另外,某个键必须是k的整数倍才被认为是坏的按键,如果不是整数倍则是正常键。

思路:使用hasht[]标记按键是否完好,正常按键标记为1,第一次遍历字符串标记出坏的按键 ,第二次遍历输出迟滞按键,使用数组isprint[]来保证输出一次,第三次遍历输出正常的字符串。

参考代码:

#include<cstdio>
#include<string>
#include<iostream>
using namespace std;
int k,hasht[256],isPrint[256];	//hasht标记是否为正常按键,正常为1,isprint标记是否输出过
int main()
{
	string s;
	cin>>k>>s;
	for(int i=0;i<s.size();){
		int flag=1,cnt=1;
		for(int j=i+1;j<s.size()&&s[j]==s[i];j++)
			cnt++;
		if(cnt%k!=0)		//迟滞次数不是k的整数倍均为正常状态
			hasht[s[i]]=1;
		i+=cnt;
	}
	for(int i=0;i<s.size();i++){
		if(!hasht[s[i]]&&!isPrint[s[i]]){	//坏键且没有输出过则输出
			cout<<s[i];
			isPrint[s[i]]=1;
		}
	}
	cout<<endl;	
	for(int i=0;i<s.size();){ 
		cout<<s[i];
		if(!hasht[s[i]]) i+=k;
		else i+=1;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值