java输入多组字符串求解给定字符串的前缀

求解给定字符串的前缀。

输入格式:

输入数目不定的多对字符串,每行两个,以空格分开。 例如:
filename filepath
Tom Jack
输出格式:

返回两个字符串的最大前缀,例如:
The common prefix is file
No common prefix ##

输入样例:

filename filepath
Tom Jack

输出样例:

The common prefix is file
No common prefix
Copyright vivi_and_qiao liwei
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;
import java.util.Map.Entry;
public class Main{
    public static void prefix(String s1,String s2)
    {
        StringBuffer sb=new StringBuffer();
        for(int i=0;i<(s1.length()<s2.length()?s1.length():s2.length());i++)
        {
            if(s1.charAt(i)==s2.charAt(i))
               sb.append(s1.charAt(i));
            else
                break;
        }
        if(sb.length()==0)
            System.out.println("No common prefix");
        else
            System.out.println("The common prefix is "+sb);
    }
    public static void main(String []args) throws IOException
    {
        /*StringBuffer sb1=new StringBuffer();
        StringBuffer sb2=new StringBuffer();
        Scanner in=new Scanner(System.in);
    String s1,s2;
    while(in.nextLine()!="")
    {
        s1=in.next();s2=in.next();
        sb1.append(s1);sb2.append(s2);
    }
    System.out.println(sb1.toString()+sb2.toString());*/
    StringBuffer sb1=new StringBuffer();
    StringBuffer sb2=new StringBuffer();
    BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
    do {
        String line = reader.readLine();
        if (line.equals("")) {
            break;
        }
        int i;
        for(i=0;i<line.length();i++)
            if(line.charAt(i)==' ')
                break;
        prefix(line.substring(0, i-1),line.substring(i+1,line.length()));
    } while (true);
    }
}
  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值