hdu 1142A Walk Through the Forest

Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
  
  
2

4

这道题很关键的是读懂题意,不是简单的求两点之间的最短距离,而是求满足要求的路径的条数,要求就是如果要从A到B,那么存在一条B到home的路径route(A到home的任何路径

都大于这条route),即A到home的最短路径大于B到home的最短路径。思路就是用dijstra算法算出home到各个结点的最短路径,作为判断条件进行记忆化搜索,直接dfs会tle。

ps:(本人弱鸡,记忆化搜索还不太熟,下篇博客详细介绍记忆化搜索)

#include<iostream>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
int map[1001][1001];
int d[1001];
int s[1001];
int path[1001];
int m,n;
void dij(){
    int i,j,v,min;
    for(i=1;i<=m;i++){
        s[i]=0;
        d[i]=map[2][i];
    }
    for(i=1;i<=m;i++){
        min=INF;
        for(j=1;j<=m;j++){
            if(s[j]==0&&d[j]<min){
                min=d[j];
                v=j;
            }
        }
        s[v]=1;
        for(j=1;j<=m;j++){
            if(s[j]==0&&d[j]>d[v]+map[v][j])
                d[j]=d[v]+map[v][j];

        }
    }

}
int  dfs(int i){
        int sum=0,k;
        if(path[i]) return path[i];
        if(i==2)  return 1;
        for(k=1;k<=m;k++){
            if(map[i][k]<INF&&d[i]>d[k]){
                if(path[k])sum=sum+path[k];
                else sum=sum+dfs(k);

            }

        }
        sum=sum+path[i];
        path[i]=sum;
        return path[i];


}
int main(){
        int i,j,a,b,c;
        while(cin>>m>>n&&m!=0){
                for(i=1;i<=m;i++){
                    for(j=1;j<=m;j++){
                        if(i==j)
                            map[i][j]=map[j][i]=0;
                        else
                            map[i][j]=map[j][i]=INF;

                    }
                }
                for(i=1;i<=n;i++){
                    cin>>a>>b>>c;
                    if(map[a][b]>c)
                        map[a][b]=map[b][a]=c;
                }
                memset(path,0,sizeof(path));
                dij();
                cout<<dfs(1)<<endl;


        }



}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值