2015 ccpc G题解

G - Ancient Go

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

Description



Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

    The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
    Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
    The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
    When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.



Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

Sample Input

2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o

Sample Output

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!

HINT

 

题意

下围棋,让你下一粒子,然后问你能否至少围住一个o

题解:

数据范围才9*9,直接瞎暴力就行了

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 1005
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))

typedef long long LL;

const int dir[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};

char s[N][N];
int vis[N][N];

int check2 (int x, int y)
{
    vis[x][y] = 1;
    if (x<0 || x>=9 || y<0 || y>=9) return 0;

    for (int i=0; i<4; i++)
    {
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];

        if (xx<0 || xx>=9 || yy<0 || yy>=9 || vis[xx][yy]) continue;

        if (s[xx][yy] == '.') return 1;

        if (s[xx][yy] == 'o' && check2 (xx, yy))
            return 1;
    }

    return 0;
}

int check1 (int x, int y)
{
    if (s[x][y] != '.') return 0;

    s[x][y] = 'x';

    for (int i=0; i<9; i++)
    {
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];

        if (xx>=0 && xx<9 && yy>=0 && yy<9 && s[xx][yy] == 'o')
        {
            met (vis, 0);
            if (!check2 (xx, yy))
                return 1;
        }
    }

    s[x][y] = '.';
    return 0;
}

int main ()
{
    int t, nCase = 1;
    scanf ("%d", &t);

    while (t--)
    {
        for (int i=0; i<9; i++)
            scanf ("%s", s[i]);

        int flag = 0;

        for (int i=0; i<9; i++)
        {
            for (int j=0; j<9; j++)
            {
                if (s[i][j] == 'o' || s[i][j] == 'x') continue;

                if (check1 (i, j))
                {
                    flag = 1;
                    s[i][j] = '.';
                    break;
                }
            }
            if (flag) break;
        }

        if (flag) printf ("Case #%d: Can kill in one move!!!\n", nCase++);
        else printf ("Case #%d: Can not kill in one move!!!\n", nCase++);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值