铁轨

也是刘汝佳书里的一道题目,题目描述很冗长,其实就是给一个出栈序列判断是否合法
样例输入:
5
1 2 3 4 5
5
5 4 3 2 1
6
6 5 4 3 2 1
样例输出:
Yes
No
Yes

#include <iostream>
#include <stack>

#define MAX 10010

using namespace std;

int main()
{
    int n = 0;
    while(cin >> n)
    {
        stack<int> s;
        int A = 1,
            B = 1,
            st[MAX] = {0};
            // n = 0;
        bool isOK = true;
        // cin >> n;
        for (int i = 1; i <= n; ++i)
        {
            cin >> st[i];
        }
        while(B <= n)
        {
            if (A == st[B])
            {
                A++;
                B++;
            }
            else if (!s.empty() && s.top() == st[B])
            {
                s.pop();
                B++;
            }
            else if (A <= n)
            {
                s.push(A++);
            }
            else
            {
                isOK = false;
                break;
            }
        }
        cout << (isOK ? "yes" : "no") << endl;
    }
    return 0;
}

坦白的讲,这个程序我并没搞明白,让我自己想破头大概也想不出来。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值