17 多校 - 2 - 1011 - Regular polygon (HDU - 6055)

5 篇文章 0 订阅

Regular polygon

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 122    Accepted Submission(s): 45


Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
 

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
 

Output
For each case, output a number means how many different regular polygon these points can make.
 

Sample Input
  
  
4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
 

Sample Output
  
  
1 2
 


题意:给你n个整点的坐标,问你能形成几个正多边形。

主要的就是点为整点,就是坐标的x和y均为整数。

官方题解:

容易得知只有正四边形可以使得所有的顶点为整数点。(具体证明可参考杨景钦在2017的国家队论文) 所以正解即求出所有的正四边形个数。

枚举2个点,然后暴力判断另外2个点的位置是否存在。

复杂度 N*N*logN。

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int n,mp[1022][1022],x[555],y[555];
int main()
{
    while(~scanf("%d",&n))
    {
        memset(mp,0,sizeof mp);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x[i],&y[i]);
            x[i]+=350;
            y[i]+=350;
            mp[x[i]][y[i]] = 1;
        }
        int ans = 0;
        int a ,b;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(j==i)
                    continue;
                a = x[j] - x[i];
                b = y[j] - y[i];
                if(mp[x[i]-b][y[i]+a]&&mp[x[i]+a-b][y[i]+b+a])
                    ans++;
                if(mp[x[i]+b][y[i]-a]&&mp[x[i]+a+b][y[i]+b-a])
                    ans++;
            }
        }
        printf("%d\n",ans/8);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值