CSU - 1563 - Lexicography

1563: Lexicography

          Time Limit:1 Sec      Memory Limit: 128 Mb      Submitted:468      Solved:150    

Description

An anagram of a string is any string that can be formed using the same letters as the original. (We consider the original string an anagram of itself as well.) For example, the string ACM has the following 6 anagrams, as given in alphabetical order:

ACM
AMC
CAM
CMA
MAC
MCA
As another example, the string ICPC has the following 12 anagrams (in alphabetical order):

CCIP
CCPI
CICP
CIPC
CPCI
CPIC
ICCP
ICPC
IPCC
PCCI
PCIC
PICC
Given a string and a rank K, you are to determine the Kth such anagram according to alphabetical order.

Input

Each test case will be designated on a single line containing the original word followed by the desired rank K. Words will use uppercase letters (i.e., A through Z) and will have length at most 16. The value of K will be in the range from 1 to the number of distinct anagrams of the given word. A line of the form "# 0" designates the end of the input.

Output

For each test, display the Kth anagram of the original string.

Sample Input

ACM 5
ICPC 12
REGION 274
# 0

Sample Output

MAC
PICC
IGNORE

Hint

The value of K could be almost 245 in the largest tests, so you should use type long in Java, or type long long in C++ to store K.

题意:求一个字符串的全排列按字典序从小到大排之后的第K个

就是排列组合的一些问题。N个不同元素的全排列为N!,若N个元素中有M中每种有ai个则其全排列为N! / a1! / a2! /... / am-1! / am!

可从前往后依次放应该放在该位置的字符,如ICPC,得到的是CCIP,第一个位置可以放'C'、'I'、'P'三种字符,第一个位置为'C'时有6种组合,'I'和'P'各有3种组合,若K在1-6之间选C,7-9之间选I,10-12之间选P,然后K各减去0、6、9,然后再按此操作往下一个位置找,直到K=0。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
using namespace std;
char s[20];
ll k,len,fact[20];
ll A(char *str)//求字符串str的全排列
{
    ll l = strlen(str);
    sort(str,str+l);
    ll ans = fact[l];
    ll cnt = 1;
    for(int i=1;i<l;i++)
    {
        ans /= cnt;
        if(str[i]==str[i-1])
            cnt++;
        else
            cnt = 1;
    }
    ans /= cnt;
    return ans ;
}
bool cmp(char a,char b)
{
    return a>b;
}
void dfs(int x,ll k)
{
    if(k==0) return;
    ll cost = A(s+x+1);
    if(cost==k)
    {
        sort(s+x+1,s+len,cmp);
        return;
    }
    else
    if(cost>k)
        dfs(x+1,k);
    else
    {
        int co = 1;
        while(cost<k)
        {
            int cnt = 0;
            for(int i=x;i<len;i++)
            {
                if(s[i]!=s[i-1]&&s[i]!=s[x])
                    cnt++;
                if(cnt==co)
                {
                    co++;
                    swap(s[x],s[i]);
                    sort(s+x+1,s+len);
                    k-=cost;
                    break;
                }
            }
            cost = A(s+x+1);
        }
        dfs(x,k);
    }
}
int main()
{
    fact[0] = fact[1] = 1;
    for(int i=2;i<=16;i++)
        fact[i] = fact[i-1] * i;
    while(~scanf("%s%lld",s,&k))
    {
        len = strlen(s);
        if(s[0]=='#'&&len==1&&k==0)
            break;
        sort(s,s+len);
        dfs(0,k);
        printf("%s\n",s);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值