HDU - 5718 - Oracle

Oracle

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1232    Accepted Submission(s): 532


Problem Description
There is once a king and queen, rulers of an unnamed city, who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche, whose admirers, neglecting the proper worship of the love goddess Venus, instead pray and make offerings to her. Her father, the king, is desperate to know about her destiny, so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer  n  without leading zeroes. 

To get the meaning, he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>, and their sum should be as large as possible. 

Help him to work out the maximum sum. It might be impossible to do that. If so, print `Uncertain`.
 

Input
The first line of the input contains an integer  T   (1T10) , which denotes the number of test cases.

For each test case, the single line contains an integer  n   (1n<1010000000) .
 

Output
For each test case, print a positive integer or a string `Uncertain`.
 

Sample Input
  
  
3 112 233 1
 

Sample Output
  
  
22 35 Uncertain
Hint
In the first example, it is optimal to split $ 112 $ into $ 21 $ and $ 1 $, and their sum is $ 21 + 1 = 22 $. In the second example, it is optimal to split $ 233 $ into $ 2 $ and $ 33 $, and their sum is $ 2 + 33 = 35 $. In the third example, it is impossible to split single digit $ 1 $ into two parts.
 

Source
 


题意:有一长度为n( n ≤ 1e7 )的无前置零数字,求重新布置该数字的每一位数之后,将其分为两部分的和最大为多少,分出的数字不能有前置零

思路:先排序,要使得和最大,其中一个数要为个位数(尽量小且不为0),剩下的都是另一个数

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL long long
const int N = 1e7 + 10;
LL T,n,len,l;
char s[N],ans[N],zero[N];
bool cmp(int a,int b) {return a>b;}
int main()
{
    scanf("%lld",&T);
    for(int i=0;i<N;i++) zero[i] = '0';
    while(T--){
        scanf("%s",s+1);
        len = strlen(s+1);
        sort(s+1,s+len+1,cmp);//从大到小排序
        if(len==1||s[2]=='0') {
            //当整个数字中的非零数少于2个时不可分为两个部分
            printf("Uncertain\n");
            continue;
        }
        //最小数为0时
        if(s[len]=='0'){
            LL pos = -1;
            //找出最小非零数所在位置
            for(LL i=len;i>=1;i--){
                if(s[i]!='0'){
                    pos = i;break;
                }
            }
            char c = s[pos];
            s[pos] = s[len] = 0;
            printf("%s%s%c\n",s+1,s+pos+1,c);
        }else{
            LL pos = -1;
            //找位数最低的非9数 --- 进位只会持续到该位置,结束后原来的9变为0
            for(LL i=len-2;i>=1;i--){
                if(s[i]!='9'){
                    pos = i;break;
                }
            }
            int num1 = s[len] - '0',num2 = s[len-1] -'0';
            //两数末尾数字
            if(num1+num2>=10){
                //产生进位
                if(pos==-1){
                    //全为9
                    zero[len-2] = 0;
                    printf("1%s%d\n",zero,(num1+num2)%10);
                    zero[len-2] = '0';
                }else{
                    zero[len-pos-2] = 0;
                    int n = s[pos] - '0' + 1;
                    s[pos] = 0;
                    printf("%s%d%s%d\n",s+1,n,zero,(num1+num2)%10);
                    zero[len-pos-2] = '0';
                }
            }else{
                //不产生进位
                s[len-1] = 0;
                printf("%s%d\n",s+1,num1+num2);
            }
        }
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值