HDU - 3466 - Proud Merchants (01背包 + 排序)

1 篇文章 0 订阅

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 7161    Accepted Submission(s): 2973


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 

Author
iSea @ WHU
 

Source
 


题意:有n件物品,每件物品有pi,qi,vi三个属性,分别代表的是购买该物品的花费,购买时至少需要持有的钱 以及该物品的价值



q属性的加入导致了要考虑购买时要考虑购买的先后顺序

设有物品A(p1,q1,v1)与物品B(p2,q2,v2),若先购买A再购买B则至少需要(p1+q2)的钱(q1≤p1+q2),若先购买B则至少需要(p2+q1)的钱(q2≤p2+q1)

哪种至少花的钱少就选哪种,如(p1+q2)<(p2+q1)时就先买物品A,可以得到此时 q1 - p1 > q2 - p2

所以按差值大的先买,dp的过程是个逆过程,所以排序时要按差值小的来


#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define LL long long
LL n,m,dp[5050];
struct node{LL p,q,v;}a[505];
bool cmp(node a,node b){
    return (a.q-a.p)<(b.q-b.p);
}
int main()
{
    while(~scanf("%lld%lld",&n,&m)){
        for(int i=0;i<n;i++){
            scanf("%lld%lld%lld",&a[i].p,&a[i].q,&a[i].v);
        }
        memset(dp,0,sizeof dp);
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++){
            for(LL j=m;j>=a[i].q;j--){
                dp[j] = max(dp[j],dp[j-a[i].p] + a[i].v);
            }
        }
        printf("%lld\n",dp[m]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值