HDU - 4786 - Fibonacci Tree (最小生成树 - Kurskal)

7 篇文章 0 订阅
2 篇文章 0 订阅

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5844    Accepted Submission(s): 1823


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Source
 

题意:无向图有N个点M条边,每条边有黑或白两种颜色,求该图是否存在一个生成树使得生成树中白边的数量为斐波那契数


白边权值为1,黑边为0,求出生成树中最少有多少条白边和最多有多少条白边,mi,mx

若区间[mi,mx]间存在斐波那契数,则必定存在一个生成树其中含有的白边数量为斐波那契数

当mi < mx 时,必定有存在(mx-mi)条黑边,将任一条黑边删去后所留下的两个连通块一定可以用一条白边连接起来

问题就变成了求最大与最小生成树的权值, 注意判断是否能够形成生成树


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int N = 1e5 +10;
int t,n,m,cas,fib[N],fa[N];
int mi, mx;
struct node {
    int from, to, cost;
}e[N];
bool cmp1(node a,node b){return a.cost<b.cost;}
bool cmp2(node a,node b){return a.cost>b.cost;}
int find(int x){
    int be = x;
    while(fa[x]!=x) x = fa[x];
    while(fa[be]!=be){
        int c = fa[be];
        fa[be] = x;
        be = c;
    }
    return x;
}
int slove(){
    int cnt = 0, ans = 0;
    for(int i=0;i<m;i++){
        int fx = find(e[i].from), fy = find(e[i].to);
        if(fx == fy) continue;
        fa[fx] = fy; cnt++; ans += e[i].cost;
        if(cnt==n-1) return ans;
    }
    return n+1;
}
int main()
{
    fib[1] = 1;
    for(int a = 1,b = 2;b<N;){
        fib[b] = 1;
        int c = b;
        b = a + b;
        a = c;
    }
    for(scanf("%d",&t),cas = 0;t--;){
        scanf("%d%d",&n,&m);
        printf("Case #%d: ",++cas);
        mx = 0; mi = n;
        for(int i=0;i<m;i++){
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            e[i].from = x; e[i].to = y; e[i].cost = z;
        }
        for(int i=1;i<=n;i++) fa[i] = i;
        sort(e,e+m,cmp1);
        mi = slove();
        if(mi>=n){
            printf("No\n");
            continue;
        }
        for(int i=1;i<=n;i++) fa[i] = i;
        sort(e,e+m,cmp2);
        mx = slove();
        bool flag = false;
        for(int i=mi;i<=mx;i++){
            if(fib[i]) {
                flag = true; break;
            }
        }
        
        if(flag) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值