BZOJ 1014 火星人 prefix (splay hash 二分答案)

1014: [JSOI2008]火星人prefix

Time Limit: 10 Sec Memory Limit: 162 MB
Description

  火星人最近研究了一种操作:求一个字串两个后缀的公共前缀。比方说,有这样一个字符串:madamimadam,
我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 现在,
火星人定义了一个函数LCQ(x, y),表示:该字符串中第x个字符开始的字串,与该字符串中第y个字符开始的字串
,两个字串的公共前缀的长度。比方说,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4, 7) = 0 在研究LCQ函数的过程
中,火星人发现了这样的一个关联:如果把该字符串的所有后缀排好序,就可以很快地求出LCQ函数的值;同样,
如果求出了LCQ函数的值,也可以很快地将该字符串的后缀排好序。 尽管火星人聪明地找到了求取LCQ函数的快速
算法,但不甘心认输的地球人又给火星人出了个难题:在求取LCQ函数的同时,还可以改变字符串本身。具体地说
,可以更改字符串中某一个字符的值,也可以在字符串中的某一个位置插入一个字符。地球人想考验一下,在如此
复杂的问题中,火星人是否还能够做到很快地求取LCQ函数的值。

Input

  第一行给出初始的字符串。第二行是一个非负整数M,表示操作的个数。接下来的M行,每行描述一个操作。操
作有3种,如下所示
1、询问。语法:Qxy,x,y均为正整数。功能:计算LCQ(x,y)限制:1<=x,y<=当前字符串长度。
2、修改。语法:Rxd,x是正整数,d是字符。功能:将字符串中第x个数修改为字符d。限制:x不超过当前字
符串长度。
3、插入:语法:Ixd,x是非负整数,d是字符。功能:在字符串第x个字符之后插入字符d,如果x=0,则在字
符串开头插入。限制:x不超过当前字符串长度

Output

  对于输入文件中每一个询问操作,你都应该输出对应的答案。一个答案一行。

Sample Input

madamimadam

7

Q 1 7

Q 4 8

Q 10 11

R 3 a

Q 1 7

I 10 a

Q 2 11

Sample Output

5

1

0

2

1

HINT

1、所有字符串自始至终都只有小写字母构成。

2、M<=150,000

3、字符串长度L自始至终都满足L<=100,000

4、询问操作的个数不超过10,000个。

对于第1,2个数据,字符串长度自始至终都不超过1,000

对于第3,4,5个数据,没有插入操作。

思路:
晃眼一看,恩,后缀数组。然后。。。就没有然后了。。。
并不知道后缀数组怎么修改。
考虑有插入和修改操作,用splay维护这个字符串,插入和修改按普通splay做,那么我们又怎么求LCQ呢,考虑hash,枚举前缀??妥妥的炸掉。所以。。。二分答案。
每个节点维护一个子树hash值,二分答案ans,不断检s[x]∼s[x+ans]和s[y]∼s[y+ans]的hash值是否一样。

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;

const int N = 100010;

char s[N];
int pow[N];

struct tree{
    int c[2], fa, val, siz, hsh;
}tr[N << 1];

void updata(int k){
    int x = tr[tr[k].c[1]].siz;
    tr[k].siz = tr[tr[k].c[0]].siz + x + 1;
    tr[k].hsh = tr[tr[k].c[0]].hsh * pow[x+1] + tr[k].val * pow[x] + tr[tr[k].c[1]].hsh;
}//hash的处理 

void rotate(int &k, int x){
    int y = tr[x].fa, z = tr[y].fa, dy = tr[y].c[1] == x;
    if(k == y) k = x;
    else tr[z].c[tr[z].c[1] == y] = x;
    tr[y].c[dy] = tr[x].c[!dy], tr[tr[x].c[!dy]].fa = y;
    tr[x].c[!dy] = y, tr[y].fa = x, tr[x].fa = z;
    updata(y);
}

void splay(int &k, int x){
    while(k != x){
        int y = tr[x].fa, z = tr[y].fa;
        if(k != y)
            if(tr[y].c[1] == x ^ tr[z].c[1] == y) rotate(k, x);
            else rotate(k, y);
        rotate(k, x);
    }
    updata(x);
}

int find(int k, int x){//找到下标第k的位置 
    if(x <= tr[tr[k].c[0]].siz) return find(tr[k].c[0], x);
    if(x == tr[tr[k].c[0]].siz + 1) return k;
    return find(tr[k].c[1], x - tr[tr[k].c[0]].siz - 1);
}

int main(){
    int n, m, x, y, root, tot;
    scanf("%s%d", s, &m);
    n = strlen(s); pow[0] = 1;
    for(int i=1; i<=N; i++) pow[i] = pow[i - 1] * 107;//hash 
    tr[1].fa = 2, tr[1].siz = 1;//在串首补上一个0,方便包含原串首的区间的处理 
    for(int i=2; i<=n+2; i++){
        tr[i].c[0] = i - 1; tr[i].fa = i + 1;
        tr[i].val = s[i-2]; updata(i);
    }//初始时是一条链 
    tr[n + 2].fa = 0; root = tot = n + 2;
    while( m-- ){
        char opt[5]; scanf("%s", opt);
        if(opt[0] == 'R'){
            scanf("%d%s", &x, opt);
            splay(root, find(root, x + 1));//实际上是把x转到了root,但是我们在串首多了一个0
            tr[root].val = opt[0]; 
            updata(root);
        }
        else if(opt[0] == 'I'){
            scanf("%d%s", &x, opt); n++;
            splay(root, find(root, x + 1));//实际上是把x转到了root,但是我们在串首多了一个0
            splay(tr[root].c[1], find(root, x + 2));
            tr[tr[root].c[1]].c[0] = ++tot;//x~x+1中间卡出一个区间
            tr[tot].val = tr[tot].hsh = opt[0];
            tr[tot].fa = tr[root].c[1];
            tr[tot].siz = 1;
            updata(tr[root].c[1]); 
            updata(root);
        }
        else{
            scanf("%d%d", &x, &y);
            if(x > y) swap(x, y);
            int l = 0, r = n - y + 2, oo = 0;
            while(l < r - 1){
                int mid = (l + r) >> 1;
                splay(root, find(root, x));//实际上是把x-1转到了root,但是我们在串首多了一个0 
                splay(tr[root].c[1], find(root, x + mid + 1));
                oo = tr[tr[tr[root].c[1]].c[0]].hsh;//x~x+mid-1这mid个字符卡在区间内 
                splay(root, find(root, y));//同理 
                splay(tr[root].c[1], find(root, y + mid + 1));
                oo -= tr[tr[tr[root].c[1]].c[0]].hsh;
                oo ? r = mid : l = mid;
            }
            printf("%d\n", l);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值