Period POJ - 1961(kmp求最大周期,最小循环节)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A  K,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.
Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
题目大意:
意思还是很简单的咯
思路:
这道题就是求一个最大周期数嘛,刚接触kmp,查了下查发现就然可以用kmp求周期和循环节,也是蛮强的
存在以下的定理:
对于字符串的前i个字符,最小循环节的长度为len=i-next【i】,如果i能整除len,说明能由某个字符串循环若干次得来,次数易得为:i/len(当然要大于一,不然这问题就没有多大的意义)
详细证明参考:http://www.cnblogs.com/chenxiwenruo/p/3546457.html
ac代码:
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
#include<iostream>
#include<sstream>
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
const int maxn = 1e6+100;
char s[maxn];
int next[maxn];
int n;
void getNext()
{
    int len = strlen(s);
    int j = 0;
    int k = -1;
    next[0] = -1;
    while(j<len)
    {
        if(k==-1||s[j]==s[k])
        {
            next[++j] = ++k;
        }
        else
            k = next[k];
    }
}
int main()
{
    int kase = 1;
    int n;
    while(~scanf("%d",&n))
    {if(n==0)
        return 0;
        scanf("%s",s);
        getNext();
        int len = strlen(s);
        if(kase>1)
            cout<<endl;
        cout<<"Test case #"<<kase++<<endl;
        for(int i = 1 ;i<len;i++)
        {
            if((i+1)%(i+1-next[i+1])==0&&(i+1)/(i+1-next[i+1])>1)
            {
                cout<<i+1<<' '<<(i+1)/(i+1-next[i+1])<<endl;
            }
        }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值