hdu 3461 Code Lock

A lock you use has a code system to be opened instead of a key. The lock contains a sequence of wheels. Each wheel has the 26 letters of the English alphabet ‘a’ through ‘z’, in order. If you move a wheel up, the letter it shows changes to the next letter in the English alphabet (if it was showing the last letter ‘z’, then it changes to ‘a’).
At each operation, you are only allowed to move some specific subsequence of contiguous wheels up. This has the same effect of moving each of the wheels up within the subsequence.
If a lock can change to another after a sequence of operations, we regard them as same lock. Find out how many different locks exist?
Input
There are several test cases in the input.

Each test case begin with two integers N (1<=N<=10000000) and M (0<=M<=1000) indicating the length of the code system and the number of legal operations.
Then M lines follows. Each line contains two integer L and R (1<=L<=R<=N), means an interval [L, R], each time you can choose one interval, move all of the wheels in this interval up.

The input terminates by end of file marker.
Output
For each test case, output the answer mod 1000000007
Sample Input
1 1
1 1
2 1
1 2
Sample Output
1
26

题意:读了半天题也没看懂啥意思(好菜) 看了博客才明白, 有一个编码系统,是一串英文字母,给你几个区间,你可以对这个区间所有的字母进行同时增加(到下一个字母),问你有几种不同的密码(如果通过增加能得到相同的密码就算是相同的)
如果一个区间都没有的话,那结果肯定是26的n(字符串长度)次方,因为有了区间,就会出现重复,每增加一个集合就会除以26,所以求出25的(n-集合数)就好了,在合并集合的时候要注意:一个集合的L的祖先列要等于R+1的祖先才行

#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
#define maxn 10001000
#define mod 1000000007
long long n,m;
int pre[maxn];
int findroot(int a)
{
    while(pre[a] != a)
    {
        a = pre[a];
    }
    return pre[a];
}
long long muli(long long a)
{
    long long ans = 1;
    long long m = 26;//一定是long long 
    while(a)
    {
        if(a % 2 == 1)
        {
            ans = (ans*m) % mod;
        }
        a /= 2;
        m = (m*m)%mod;
    }
    return ans%mod;
}
int main()
{
    while(~scanf("%lld%lld",&n,&m))
    {
        long long cnt = 0;
        for(int i =1; i <= n+1; i++)
        {
            pre[i] = i;
        }
        for(int i = 1; i <= m; i++)
        {
            int l,r;
            scanf("%d%d",&l,&r);
            if(findroot(l) != findroot(r+1))
            {
                int roota = findroot(l);
                int rootb = findroot(r+1);
                pre[roota] = rootb;
                cnt++;
            }
        }
        printf("%lld\n",muli(n-cnt)%mod);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值