求二叉树的层次遍历

求二叉树的层次遍历
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

已知一颗二叉树的前序遍历和中序遍历,求二叉树的层次遍历。
Input

输入数据有多组,输入T,代表有T组测试数据。每组数据有两个长度小于50的字符串,第一个字符串为前序遍历,第二个为中序遍历。
Output

每组输出这颗二叉树的层次遍历。
Example Input

2
abc
bac
abdec
dbeac
Example Output

abc
abcde
Hint

Author

fmh

这个题是根据前序和中序重建二叉树,然后在求层序遍历。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char a[55];
char b[55];
struct node
{
    int data;
    struct node *l, *r;
};
struct node *creat(int n, char *a, char *b)//重建二叉树
{
    int i;
    struct node *root;
    if(n == 0) return NULL;
    root = (struct node *) malloc(sizeof(struct node));
    root -> data = a[0];
    for(i = 0; i < n; i++)
    {
        if(b[i] == a[0])
            break;
    }
    root -> l = creat(i, a+1, b);
    root -> r = creat(n-1-i, a+i+1, b+i+1);
    return root;//重建完成
};
void cengxu(struct node *root)//求层序遍历
{
    int in = 0, out = 0;
    struct node *p[100];//用于储存每一层的数据
    p[in++] = root;
    while(in > out)
    {
        if(p[out])
        {
            printf("%c", p[out] -> data);
            p[in++] = p[out] -> l;
            p[in++] = p[out] -> r;
        }
        out++;
    }
}
int main()
{
    int t, n;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s%s",a , b);
        n = strlen(a);
        struct node *root;
        root = creat(n, a, b);
        cengxu(root);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值