C/C++训练1---最大公约数与最小公倍数(JAVA)

Problem Description

输入两个正整数,求它们的最大公约数与最小公倍数。
Input

输入两个正整数,两个整数之间用空格分开。
数据保证在 int 范围内。
Output

第一行输出最大公约数;
第二行输出最小公倍数。
答案保证在 int 范围内。
Sample Input

64 48
Sample Output

16
192

package sss;

import java.util.Scanner;

class math
{
    int a, b, t;
    public math(int a, int b) {
        super();
        this.a = a;
        this.b = b;
        if(a < b)
        {
            t = a;
            a = b;
            b = t;
        }
    }
    public int yue(int a, int b)
    {
        int c = 1;
        while(c > 0)
        {
            c = a % b;
            a = b;
            b = c;
        }
        return a;
    }

    public int bei(int a, int b)
    {
        int c = 1, m = a, n = b;
        while(c > 0)
        {
            c = a % b;
            a = b;
            b = c;
        }
        return (m*n)/a;
    }
}

public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner str = new Scanner(System.in);
        int a, b;
        a = str.nextInt();
        b = str.nextInt();
        math c = new math(a, b);
        System.out.println(c.yue(a, b));
        System.out.println(c.bei(a, b));
        str.close();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值