FZU 2214 变通思想 : 01背包

FZU 2214 Knapsack problem


Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

15 1512 42 21 14 101 2

Sample Output

15



    比赛的时候做到一道题目,一看就是01背包,提笔要做的时候,发现了一个严峻的问题,背包容量太大了,用以往的方法根本行不通,这时发现value的和有限制,题目要求其不超过5000,此时变通一下思想,不妨在限制value的情况下,求满足B条件下,尽量多的value值

#include <iostream>
#include <cstdio>
#include <cstring>
#define inf 0x3f3f3f3f
#define maxn 5000+5
#define s_(x) scanf("%d",&x)//!新发现的输入输出方法,很省事
#define p_(x) printf("%d",x)
using namespace std;

int min(int a,int b)
{
    return a<b?a:b;
}
int w[maxn],v[maxn],dp[maxn],T,n,B,sum;
int main()
{
 s_(T);
    while(T--)
    {
       int sum=0;
      s_(n);s_(B);
     for(int i=0;i<n;++i)
      {
          cin>>w[i]>>v[i];
          sum+=v[i];
      }

      for(int i=0;i<=sum;i++) dp[i]=inf;
       dp[0]=0;

     for(int i=0;i<n;++i)
      {
          for(int j=sum;j>=v[i];--j)
          {
              dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
          }
      }

      for(int i=sum;i>=0;--i)
      {
          if(dp[i]<=B)
          {
              cout<<i<<endl;
              break;
          }
      }

    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值