数据结构实验之求二叉树后序遍历和层次遍历

Problem Description

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。

Sample Input

2
abdegcf
dbgeafc
xnliu
lnixu

Sample Output

dgebfca
abcdefg
linux
xnuli

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char data;
    struct node *lc;
    struct node *rc;
};
struct node *creat(int n,char *a,char *b)
{
    struct node *root;
    char *p;
    if(n==0) return NULL;//若n=0,则证明没有结点,树为空
    root=(struct node *)malloc(sizeof(struct node));
    root->data=a[0];//根结点为前序遍历的第一个字符
    for(p=b;p!='\0';p++)
    {
        if(*p==a[0]) break;
    }//通过指针,找到中序遍历中的根结点的位置,从而确定了根结点左子树和右子树
    int m;
    m=p-b;
    root->lc=creat(m,a+1,b);//创建根结点的左子树
    root->rc=creat(n-m-1,a+m+1,p+1);//创建根结点的右子树
    return (root);
}//树的创建通过递归完成
void last(struct node *root)
{
    if(root!=NULL)
    {
        last(root->lc);
        last(root->rc);
        printf("%c",root->data);
    }
}//后序遍历树
int deep(struct node *root)
{
    int ld,rd;
    if(root==NULL) return 0;
    else
    {
        ld=deep(root->lc);
        rd=deep(root->rc);
        if(ld>rd) return (ld+1);
        else return (rd+1);
    }
}
void cengci(struct node *root)
{
    struct node *p[10001];
    int rear=0,front=0;//定义一个头指针和尾指针,当头尾指针相同时,则遍历完了所有结点
    if(root!=NULL)
    {
        printf("%c",root->data);
        p[rear++]=root;
    }//判断树是否为空,若为非空,则输出根结点
    while(rear>front)//依次遍历根结点的左孩子和右孩子,直到层次遍历完所有结点
    {
        root=p[front++];//找到根结点
        if(root->lc!=NULL)//判断根结点的左孩子是否为空
        {
            printf("%c",root->lc->data);
            p[rear++]=root->lc;
        }//若为非空,则输出根结点的左孩子的值,并且将下一判断结点置为根结点的左孩子
        if(root->rc!=NULL)//判断根结点的右孩子是否为空
        {
            printf("%c",root->rc->data);
            p[rear++]=root->rc;
        }//若为非空,则输出根结点的右孩子的值,并且将下一判断结点置为根结点的右孩子
    }
}
int main()
{
    struct node *root;
    int n;
    char a[10001],b[10001];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s%s",a,b);
        root=creat(strlen(a),a,b);
        last(root);
        printf("\n");
        cengci(root);
        printf("\n");
    }
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值