Problem Description
根据给定的输入序列建立一棵平衡二叉树,求出建立的平衡二叉树的树根。
Input
输入一组测试数据。数据的第1行给出一个正整数N(n <= 20),N表示输入序列的元素个数;第2行给出N个正整数,按数据给定顺序建立平衡二叉树。
Output
输出平衡二叉树的树根。
Sample Input
5 88 70 61 96 120
Sample Output
70
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
int data;
int d;//记录树的深度
struct node *lc;
struct node *rc;
}BiTree;
int max(int x,int y)
{
if(x>y) return x;
else return y;
}
int depth(BiTree *root)
{
if(root==NULL)
return -1;
else return root->d;
}
BiTree *LL(BiTree *root)
{
BiTree *p;
p=root->lc;
root->lc=p->rc;
p->rc=root;
p->d=max(depth(p->lc),depth(p->rc))+1;
root->d=max(depth(root->lc),depth(root->rc))+1;
return p;
}//右旋
BiTree *RR(BiTree *root)
{
BiTree *p;
p=root->rc;
root->rc=p->lc;
p->lc=root;
p->d=max(depth(p->lc),depth(p->rc))+1;
root->d=max(depth(root->lc),depth(root->rc))+1;
return p;
}//左旋
BiTree *LR(BiTree *root)
{
root->lc=RR(root->lc);//先做右旋
return LL(root);//再做左旋
}
BiTree *RL(BiTree *root)
{
root->rc=LL(root->rc);//先做左旋
return RR(root);//再做右旋
}
BiTree *creat(BiTree *root,int n)
{
if(root==NULL)
{
root=(BiTree *)malloc(sizeof(BiTree));
root->data=n;
root->d=0;
root->lc=NULL;
root->rc=NULL;
}
else if(root->data>n)
{
root->lc=creat(root->lc,n);
if(depth(root->lc)-depth(root->rc)>1)
{
if(root->lc->data>n)
root=LL(root);
else root=LR(root);
}
}
else if(root->data<n)
{
root->rc=creat(root->rc,n);
if(depth(root->rc)-depth(root->lc)>1)
{
if(root->rc->data>n)
root=RL(root);
else root=RR(root);
}
}
root->d=max(depth(root->lc),depth(root->rc))+1;
return root;
}
int main()
{
int n,m,i;
scanf("%d",&n);
BiTree *root;
root=NULL;
for(i=1;i<=n;i++)
{
scanf("%d",&m);
root=creat(root,m);
}
printf("%d\n",root->data);
return 0;
}