数据结构实验之查找三:树的种类统计

Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Sample Input

2
This is an Appletree
this is an appletree

Sample Output

this is an appletree 100.00%

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
    char data[1001];
    struct node *lc;
    struct node *rc;
    int num;
}BiTree;
BiTree *creat(BiTree *root,char s[])
{
    if(root==NULL)//根结点为空
    {
        root=(BiTree *)malloc(sizeof(BiTree));//根结点不存在,要申请根结点
        root->lc=NULL;
        root->rc=NULL;
        root->num=1;
        strcpy(root->data,s);
    }
    else
    {
        if(strcmp(root->data,s)==0)
        {
            root->num++;
        }
        else if(strcmp(root->data,s)>0)
        {
            root->lc=creat(root->lc,s);
        }
        else if(strcmp(root->data,s)<0)
            root->rc=creat(root->rc,s);
    }
    return (root);
}
void middle(BiTree *root,int n)
{
    if(root!=NULL)
    {
        middle(root->lc,n);
        printf("%s %.2lf%%\n",root->data,(100.0*root->num)/n);
        middle(root->rc,n);
    }
}//中序遍历
int main()
{
    char a[1001];
    int n,i,t;
    scanf("%d",&n);
    t=n;
    getchar();
    BiTree *root;
    root=(BiTree *)malloc(sizeof(BiTree));
    root=NULL;
    while(n--)
    {
        gets(a);
        int k=strlen(a);
        for(i=0;i<=k-1;i++)
        {
            if(a[i]>='A'&&a[i]<='Z')
            {
                a[i]=a[i]+32;
            }
        }
        root=creat(root,a);
    }
    middle(root,t);
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值