gcd蛋糕上的草莓是蛋糕的灵魂

问题

Problem Description

Input

 Output

Sample Input

2
2 8
10 5

Sample Output 

8 1
5 2

 题解

两种情况:

1.不用切(x%y==0)。

2.只切草莓(至少要切一刀)变为了2x和y

对2x和y求最小公倍数。

 代码

#include<bits/stdc++.h>
#define int long long 
using namespace std;
signed main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int x,y;
		cin>>x>>y;
		if(x%y==0)//不用切 
		{
		cout<<y<<' '<<x/y<<endl;
		continue;
		}
    	//只切草莓
		//至少切一刀为2x 
		int k=2x*y/__gcd(2x,y);//最小公倍数 
		cout<<y<<' '<<k/y<<endl; 		
	}
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值