OpenJudge 024:Gone Fishing
描述
John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,…,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.
输入
You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.
输出
For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.
样例输入
2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0
样例输出
45, 5
Number of fish expected: 31
240, 0, 0, 0
Number of fish expected: 480
115, 10, 50, 35
Number of fish expected: 724
思路
这是一道贪心算法题目,难点就是你在这个湖钓鱼的时候不清楚如果把相同的时间花在后面的湖会不会钓到更多的鱼,之后会想能不能通过循环遍历来把可能在后面钓到的鱼的最大个数求出来,与这个湖的进行比较。。。这样想的话这题会越想越复杂,要换一个思路,首先确定你停在哪一个湖里面,之后你走路的时间就确定下来了,钓鱼时间也确定下来了,之后开一个数组,里面放着每个湖可以钓到的最大的鱼数,之后按照时间一个一个选最优的那个,就出来了;
#include<iostream>
#include<map>
#include<functional>
#include<string.h>
#include<iterator>
using namespace std;
int nlakes;
int fishOflakes[25];
int decreaseOffish[25];
int timeOfways[25];
int Time;
int endPaths[25];
int maxfish;
int maxfishstoplake;
int main(void) {
int T;
cin >> T;
while (T--) {
cin >> nlakes>>Time;
Time = 12 * Time;
for (int i = 0; i < nlakes; ++i) {
cin >> fishOflakes[i];
}
for (int i = 0; i < nlakes; ++i) {
cin >> decreaseOffish[i];
}
for (int i = 0; i < nlakes - 1; ++i) {
cin >> timeOfways[i];
}
maxfish = 0;
memset(endPaths, 0, sizeof(endPaths));
maxfishstoplake = -1;
for (int stop = 0; stop < nlakes; ++stop) {
int waystime=0;
for (int i = 0; i <= stop - 1; ++i) {
waystime += timeOfways[i];
}
int time = Time - waystime;
multimap<int, int,greater<int>> Fish;
for (int i = 0; i <= stop; ++i) {
Fish.insert(make_pair(fishOflakes[i], i));
}
// multimap<int, int,greater<int>>::iterator s;
int fishes=0;
while (time--) {
int s = Fish.begin()->first;
fishes += s;
int newfish;
newfish = s - decreaseOffish[Fish.begin()->second];
if (newfish < 0) {
newfish = 0;
}
int lakes = Fish.begin()->second;
Fish.erase(Fish.begin());
Fish.insert(make_pair(newfish,lakes));
}
Fish.clear();
if (fishes > maxfish) {
maxfish = fishes;
maxfishstoplake = stop;
}
}
int waystimes = 0;
for (int i = 0; i <= maxfishstoplake - 1; ++i) {
waystimes += timeOfways[i];
}
int times = Time - waystimes;
multimap<int, int, greater<int>> Fish;
for (int i = 0; i <= maxfishstoplake; ++i) {
Fish.insert(make_pair(fishOflakes[i], i));
}
while (times--) {
int s = Fish.begin()->first;
int e = Fish.begin()->second;
endPaths[e]+=s;
s = s - decreaseOffish[e];
if (s < 0) {
s = 0;
}
Fish.erase(Fish.begin());
Fish.insert(make_pair(s, e));
}
cout << maxfish <<","<<maxfishstoplake<< endl;
for (int i = 0; i <= maxfishstoplake; ++i) {
cout << endPaths[i] << " ";
}
cout << endl;
cin.get();
}
}