PAT甲级1008. Elevator(20)

1008. Elevator(20)
The highest building in our city has only one elevator.A request list is made up with N positive numbers.The numbers denote at which floors the elevator will stop, in specified order.It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor.The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list.The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification :
Each input file contains one test case.Each case contains a positive integer N, followed by N positive numbers.All the numbers in the input are less than 100.
Output Specification :
For each test case, print the total time on a single line.
Sample Input :
3 2 3 1

Sample Output :

41

翻译:

电梯

我们城市的最高楼只有一部电梯。一个请求表是由N个正数组成的。这些数字代表电梯将以特定的顺序在哪些楼层停靠。电梯每上一层需要花费6秒钟,每下一层需要花费4秒钟。电梯在每层停靠5秒钟。

给定一个请求表,你要计算出完成这个表上的要求总共花费的时间。电梯在开始的时候停在第0层,而且要求完成的时候不需要返回最底层。

输入格式:

每个输入文件包含一个测试用例。每个用例包含一个正数N,紧接着是N个正数,所有的输入的数字都小于100.

输出格式:

对每一个测试用例,在一行里打印出总时间。

样例输入:

3 2 3 1

样例输出:

41

分析;每移动一层判断向上还是向下,加一次移动时间,加一次停靠时间。

#include<iostream>
#include<string>
using namespace std;
int main()
{
	int N, now_floor=0,next_floor, i;//当前楼层,下一个楼层
	int time = 0;//总时间
	cin >> N;
	for (i = 0; i < N; i++)
	{
		cin >> next_floor;//输入下一个楼层
		if (now_floor - next_floor > 0)//下移
			time += (now_floor - next_floor) * 4;
		else                           //上移
			time += (next_floor - now_floor)*6;
		time += 5;//停靠5s
		now_floor = next_floor;//更新当前楼层
	}
	cout << time;
}











评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值