poj 2828 - Buy Tickets

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


题解:由于数据太大,暴力失败。用线段树却可以解决。因为最后插入队列的肯定是在该位置。所以逆序插入是一种不错的选择。每个点表示了该区间的剩余空位。如果一个位置小于等于该点的左孩子空位,那么肯定插入左区间,但是如果大于该空位,就减去左区间的空位,得到了该人应该在右区间的应该排的位置。其实说起来也很乱,只要你画图模拟一下就会知道其中道理了。


#include <iostream>
#include <cstdio>
#include <cstring>
#define mem(a) memset(a,0,1izeof(a));

using namespace std;

int pos[200005];   
int value[200005];  
int res[200005];   //保存结果 
int arr[800005];   //记录线段树 

void pushUp(int k)
{
	arr[k] = arr[k << 1] + arr[(k << 1) | 1]; //更新父节点的空位数量 
}

void segTree(int k,int l,int r)
{
	if(l == r)
	{
		arr[k] = 1;  //叶子初始都是1 
		return;
	}
	segTree(k << 1,l,(l + r) >> 1);
	segTree((k << 1) | 1,(l + r) / 2 + 1,r);
	pushUp(k);
}

void update(int k,int l,int r,int x,int y)
{
	if(l == r)
	{
		arr[k] = 0;   //该位置被占了,变为0 
		res[l] = y;   //记录该点的结果 
		return;
	}
	int mid = (l + r) >> 1;
	if(x <= arr[k << 1])   //该位置小于等于左孩子空位数,说明插入左孩子,
	{                      //因为该位置前面的人肯定是x - 1 
		update(k << 1,l,mid,x,y);
	}
	else
	{              //插入右孩子,这里仔细思考,前面位置被占用相当于这人后移 
		update((k << 1) | 1,mid + 1,r,x - arr[k << 1],y);
	}
	pushUp(k);
}

int main()
{
	int n;
	while(scanf("%d",&n) != EOF)
	{
		for(int i = 1;i <= n;i++)
		{
			scanf("%d%d",&pos[i],&value[i]);
		}
		
		segTree(1,1,n);
		for(int i = n;i > 0;i--)
		{
			update(1,1,n,pos[i] + 1,value[i]);
		}
		
		for(int i = 1;i < n;i++)
		{
			printf("%d ",res[i]);
		}
		printf("%d\n",res[n]);
	}
	
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值