Cow Contest

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2


题解:弗洛伊德传递闭包。如果该点和其他点都有路径相连,说明该点排名确定,否则不能。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

const int INF = 0x3fffffff;

bool map[120][120];

void floyd(int n)
{
	for(int k = 1;k <= n;k++)
	{
		for(int i = 1; i<= n;i++)
		{
			for(int j = 1;j <= n;j++)
			{
				if(map[i][k] && map[k][j])
				{
					map[i][j] = true;   //i->j有路,可以说成i在j的前面 
				}
			}
		}
	}
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m) != EOF)
	{
		memset(map,false,sizeof(map));
		int u,v;
		for(int i = 0;i < m;i++)
		{
			scanf("%d%d",&u,&v);
			map[u][v] = true;
		}
		
		floyd(n);
		int cnt = 0;
		for(int i = 1; i<= n;i++)
		{
			bool flag = true;
			for(int j = 1; j <= n;j++)
			{
				if(i != j)
				{
					if(!map[i][j] && !map[j][i]) //i不在j前面并且j不在i前面,说明关系不确定 
					{
						flag = false;
						break;
					}
				}
			}
			if(flag)
			{
				cnt++;
			}
		}
		
		printf("%d\n",cnt);
	}
	
	
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值