HDU-5326-Work【并查集(有向)】

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1716    Accepted Submission(s): 1032


Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
  
  
2

题意:给出 n-1 种 某人 领导 某人 的直接关系,问有几人 领导的是 k 个人,领导包括直接领导、间接领导

思路:用数组 cnt [ i ] 记录 i 节点领导的人数,再做一个循环,遍历一下,找出领导 k 个人的人数

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a,b,n,k,cnt[110],fa[110];
void jisuan(int x)
{
	while(x!=fa[x])
	{
		cnt[fa[x]]++;   // x 的父节点管理人数加 1 
		x=fa[x];
	}	
}
int main()
{
	while(~scanf("%d %d",&n,&k))
	{
		memset(cnt,0,sizeof(cnt));
		for(int i=1;i<=n;i++)
		{
			fa[i]=i;
		}
		for(int i=1;i<n;i++)
		{
			scanf("%d %d",&a,&b);
			fa[b]=a;
		}
		for(int i=1;i<=n;i++)
		{
			jisuan(i);
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			if(cnt[i]==k)
			{
				ans++;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值