poj-1985-Cow Marathon【树的直径】

Cow Marathon
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5018 Accepted: 2441
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

主要是两种比较最大路径的方法,代码1运行时间可能会比代码2长;

代码1:

#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
const int Q=1e5+10;
using namespace std;
int n,m;
struct node
{
	int from,to,val,next;
}road[Q*2];
int head[Q];
int num;
void init()
{
	memset(head,-1,sizeof(head));
	num=0;
}
void addedge(int u,int v,int w)
{
	road[num].from=u;
	road[num].to=v;
	road[num].val=w;
	road[num].next=head[u];
	head[u]=num++;
}
int ans;
int Tnode;
bool vis[Q];
int dist[Q];
void BFS(int x)
{
	memset(vis,false,sizeof(vis));
	memset(dist,0,sizeof(dist));
	queue<int> qu;
	qu.push(x);
	vis[x]=true;	ans=0;
	while(!qu.empty())
	{
		int u=qu.front();	qu.pop();
		for(int i=head[u];i!=-1;i=road[i].next)
		{
			int v=road[i].to;
			if(!vis[v]&&dist[v]<dist[u]+road[i].val)
			{
				dist[v]=dist[u]+road[i].val;
				if(ans<dist[v])
				{
					ans=dist[v];
					Tnode=v;
				}	
				vis[v]=true;
				qu.push(v);
			}
		}
	}
}
int main()
{
	scanf("%d %d",&n,&m);
	int a,b,c;
	char str[2];
	init();
	while(m--)
	{
		scanf("%d %d %d %s",&a,&b,&c,&str);
		addedge(a,b,c);
		addedge(b,a,c);
	}
	BFS(1);	BFS(Tnode);
	printf("%d\n",ans);
	return 0;
}


代码2:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int MAXN = 300000 + 10;
struct Edge
{
    int from, to, val, next;
};
Edge edge[MAXN * 2];
int head[MAXN];//每个节点的头“指针”
int edgenum;//总边数
void init()
{
    memset(head, -1, sizeof(head));
    edgenum = 0;
}
void addEdge(int u, int v, int w)
{
    edge[edgenum].from = u;
    edge[edgenum].to = v;
    edge[edgenum].val = w;
    edge[edgenum].next = head[u];// u 节点的头"指针 "
    head[u] = edgenum++;
}

int ans;//记录最后结果
int Tnode;//记录S-T的端点
int dist[MAXN];//以该节点结尾的最长路
bool vis[MAXN];//标记节点是否被访问过
int n,m;
void BFS(int s)
{
    memset(dist, 0, sizeof(dist));
    memset(vis, false, sizeof(vis));
    queue<int> Q;
    Q.push(s);
    vis[s] = true; dist[s] = 0; ans = 0;
    while(!Q.empty())
    {
        int u=Q.front(); Q.pop();
        for(int i=head[u]; i!= -1; i=edge[i].next)
        {
            int v = edge[i].to;
            if(!vis[v])
            {
                if(dist[v]<dist[u]+edge[i].val)
                {
                    dist[v]=dist[u]+edge[i].val;
                }
                vis[v] = true;
                Q.push(v);
            }
        }
    }
    for(int i = 1; i <= n; i++)
    {
        if(ans < dist[i])
        {
            ans = dist[i];
            Tnode = i;   // 记录端点 
        }
    }
}
int main()
{
	scanf("%d %d",&n,&m);
	int a,b,c;
	char str[2];
	init();
	while(m--)
	{
		scanf("%d %d %d %s",&a,&b,&c,&str);
		addEdge(a,b,c);
		addEdge(b,a,c);
	}
	BFS(1);	BFS(Tnode);
	printf("%d\n",ans);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值