玲珑学院-1010-Alarm【打表】【找规律】【思维】

题目链接:点击打开链接
1010- Alarm

Time Limit:1s Memory Limit:128MByte

Submissions:236Solved:82

DESCRIPTION
Given a number sequence [3,7,22,45,116,...][3,7,22,45,116,...]. Please tell me the kk-th number.
INPUT
A number T (T<100)T (T<100) indicates the number of the input cases. Then for each case there only is one integer k (1k10000)k (1≤k≤10000).
OUTPUT
For each case, ouput the kk-th number of the sequence in one line.
SAMPLE INPUT
2
1
4
SAMPLE OUTPUT
3
45

题解:规律就是第 n 个素数的平方减去n:2 ^ 2 - 1,3 ^ 2 - 2,5 ^ 2 - 3,7 ^ 2 - 4,11 ^ 2 - 5 ............

贴个水水的代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAX=1e7;
typedef long long LL;
bool sushu[MAX+10]={1,1};
LL a[MAX+10];
void init()
{
	for(LL i=1;i<=MAX;i++)
	{
		if(sushu[i]==1)	continue;
		for(LL j=i*2;j<=MAX;j=j+i)
		{
			sushu[j]=1;
		}
	}
	LL k=1;
	for(LL i=2;i<=MAX;i++)
	{
		if(sushu[i]==0)
		{
			a[k++]=i;
		}
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	init();
	while(t--)
	{
		int n;
		scanf("%d",&n);
		printf("%lld\n",a[n]*a[n]-n);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值