poj-2264-Advanced Fruits【LCS】(回溯输出)

题目链接:点击打开链接

Advanced Fruits
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2195 Accepted: 1074 Special Judge

Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 
A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. 
Input is terminated by end of file.

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

Sample Input

apple peach
ananas banana
pear peach

Sample Output

appleach
bananas
pearch

题意:就是输出两个字符串加起来的字符串,但是最长公共子串只输出一次;

题解:

在LCS里面更多的是求最长公共子序列的长度。这里是要求输出最长公共子序列。 我们知道长度是一定的,但是最长公共子序列可能有多个。  在dp的状态转移方程我们只能求出长度, 该怎么根据状态转移方程输出序列呢? 

设ax 和 by分别是两个字符串末尾的字符。  那么字符串A和B的最长公共子序列怎么求?  如果 ax==by,那么
dp[x][y]=dp[x-1][y-1]+1。  如果ax != by,那么 dp[x][y] = max(dp[i-1][j],dp[i][j-1])。   在当 ax=by时,那么ax被记录在当前最长公共子序列中,不相等时,我们查找的是 dp[x-1][y]与 dp[x][y-1] 哪个长度1更长。  根据这个思路我们记录下每次对字符的选择,最后从ax ,ay开始往前回溯,打印出最长公共子序列

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char a[110],b[110];
int dp[110][110],mark[110][110];
void LCS(int alen,int blen)
{
	memset(dp,0,sizeof(dp));
	for(int i=0;i<alen;i++)
		mark[i][0]=1;
	for(int i=0;i<blen;i++)
		mark[0][i]=-1;
	for(int i=1;i<=alen;i++)
	{
		for(int j=1;j<=blen;j++)
		{
			if(a[i-1]==b[j-1])
			{
				dp[i][j]=dp[i-1][j-1]+1;
				mark[i][j]=0;
			}
			else if(dp[i-1][j]>=dp[i][j-1])
			{
				dp[i][j]=dp[i-1][j];
				mark[i][j]=1;
			}
			else
			{
				dp[i][j]=dp[i][j-1];
				mark[i][j]=-1;
			}
		}
	}
}
void Out(int x,int y)
{
	if(!x&&!y)	return ;
	else if(mark[x][y]==0)
	{
		Out(x-1,y-1);
		putchar(a[x-1]);
	}
	else if(mark[x][y]==1)
	{
		Out(x-1,y);
		putchar(a[x-1]);
	}
	else if(mark[x][y]==-1)
	{
		Out(x,y-1);
		putchar(b[y-1]);
	}
}
int main()
{
	while(~scanf("%s %s",a,b))
	{
		int alen=strlen(a);
		int blen=strlen(b);
		LCS(alen,blen);
		Out(alen,blen);
		puts("");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值