HDU-4324【拓扑排序&&判环】

题目链接:点击打开链接

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4673    Accepted Submission(s): 1840


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No

大意: T组测试数据,每组数据一个 n 表示 n 个人,接下 n * n 的矩阵表示这些人之间的关系,输入一定满足若 A 不喜欢 B 则 B 一定喜欢 A ,且不会出现 A 和 B 相互喜欢的情况,问你这些人中是否存在三角恋。

思路:建一个图,图中任意两点之间要么有正向边,要么有反向边。判断是否含有 a -> b -> c -> a 的三角形环。其实只要有环,就能构成三角形环。因为任意两点之间要么有正向边,要么有反向边。如果现在有一个四元素环 a -> b -> c -> d -> a,若 a 不指向 c,则 c 必定指向 a(画图理解吧),所以必定存在三角形环。直接拓扑排序,如果不能排序,则有三角环,出“Yes”,能拓扑排序,则不含有三角环,输出"No"。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n;
char s[2010][2010];
bool map[2010][2010];
int indegree[2010];
bool topo()
{
	int i,x;
	for(int cnt=1;cnt<=n;cnt++)
	{
		for(i=1;i<=n;i++)
		{
			if(indegree[i]==0)
			{
				x=i;
				break;
			}
		}
		if(i>n)	return 1; // 已存在环 
		indegree[x]=-1;
		for(i=1;i<=n;i++)
		{
			if(map[x][i])
				indegree[i]--;
		}
	}
	return 0;
}
int main()
{
	int t,text=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		for(int i=0;i<n;i++)
		{
			scanf("%s",s[i]);
			for(int j=0;j<n;j++)
			{
				if(s[i][j]=='1')
				{
					if(!map[i+1][j+1])
					{
						map[i+1][j+1]=1;
						indegree[j+1]++;	
					}
				}
			}	
		}
		if(topo())
			printf("Case #%d: Yes\n",++text);
		else
			printf("Case #%d: No\n",++text);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值