HDU 1069:Monkey and Banana(DP)

38 篇文章 0 订阅

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19928    Accepted Submission(s): 10609

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意

有n种砖块,每种砖块的长宽高已知,每种砖块个数无限,选出一些砖块建塔,要求在下面砖块的长和宽大于上面砖块的长宽,在满足这个要求的情况下,塔的最大高度

思路

每次输入一种砖块的长宽高,把这种砖的摆放情况情况枚举出来,存到结构体中,然后dp就行了

AC代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <string>
#define ll long long
#define ms(a) memset(a,0,sizeof(a))
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
const double E=exp(1);
const int maxn=1e3+10;
using namespace std;
struct wzy
{
	int a,b,c;//长宽高
	int dp;
}p[maxn];
bool cmp(wzy u,wzy v)
{
	if(u.a==v.a)
		return u.b<v.b;
	return u.a<v.a;
}
int main(int argc, char const *argv[])
{
	ios::sync_with_stdio(false);
	int n;
	int t=0;
	int x,y,z;
	while(cin>>n&&n)
	{
		ms(p);
		int k=0;
		for(int i=0;i<n;i++)
		{
			cin>>x>>y>>z;
			if(x==y)
			{
				if(x==z)
				{
					p[k].a=x;p[k].b=y;p[k].c=z;p[k].dp=p[k].c;k++;
				}
				else
				{
					p[k].a=x;p[k].b=y;p[k].c=z;p[k].dp=p[k].c;k++;
					p[k].a=x;p[k].b=z;p[k].c=y;p[k].dp=p[k].c;k++;
					p[k].a=z;p[k].b=x;p[k].c=y;p[k].dp=p[k].c;k++;
				}
			}
			else
			{
				if(y==z)
				{
					p[k].a=x;p[k].b=y;p[k].c=z;p[k].dp=p[k].c;k++;
					p[k].a=y;p[k].b=z;p[k].c=x;p[k].dp=p[k].c;k++;
					p[k].a=z;p[k].b=x;p[k].c=y;p[k].dp=p[k].c;k++;
				}
				else if(x==z)
				{
					p[k].a=x;p[k].b=y;p[k].c=z;p[k].dp=p[k].c;k++;
					p[k].a=x;p[k].b=z;p[k].c=y;p[k].dp=p[k].c;k++;
					p[k].a=y;p[k].b=x;p[k].c=z;p[k].dp=p[k].c;k++;
				}
				else
				{
					p[k].a=x;p[k].b=y;p[k].c=z;p[k].dp=p[k].c;k++;
					p[k].a=x;p[k].b=z;p[k].c=y;p[k].dp=p[k].c;k++;
					p[k].a=y;p[k].b=x;p[k].c=z;p[k].dp=p[k].c;k++;
					p[k].a=y;p[k].b=z;p[k].c=x;p[k].dp=p[k].c;k++;
					p[k].a=z;p[k].b=y;p[k].c=x;p[k].dp=p[k].c;k++;
					p[k].a=z;p[k].b=x;p[k].c=y;p[k].dp=p[k].c;k++;
				}
			}
		}
		sort(p,p+k,cmp);
		int ans=0;
		for(int i=1;i<k;i++)
		{
			for(int j=0;j<i;j++)
			{
				if(p[i].a>p[j].a&&p[i].b>p[j].b)
					p[i].dp=max(p[i].dp,p[j].dp+p[i].c);
			}
			ans=max(ans,p[i].dp);
		}
		cout<<"Case "<<++t<<": maximum height = ";
		cout<<ans<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值