ACM-ICPC 2018 沈阳赛区网络预赛-D:Made In Heaven(K短路+A*模板)

Made In Heaven

One day in the jail, F·F invites Jolyne Kujo (JOJO in brief) to play tennis with her. However, Pucci the father somehow knows it and wants to stop her. There are N spots in the jail and MM roads connecting some of the spots. JOJO finds that Pucci knows the route of the former (K−1)-th shortest path. If Pucci spots JOJO in one of these K−1 routes, Pucci will use his stand Whitesnake and put the disk into JOJO's body, which means JOJO won't be able to make it to the destination. So, JOJO needs to take the K-th quickest path to get to the destination. What's more, JOJO only has T units of time, so she needs to hurry.

JOJO starts from spot S, and the destination is numbered E. It is possible that JOJO's path contains any spot more than one time. Please tell JOJO whether she can make arrive at the destination using no more than T units of time.

Input

There are at most 50 test cases.

The first line contains two integers N and M(1≤N≤1000,0≤M≤10000). Stations are numbered from 1 to N.

The second line contains four numbers S,E,K and T ( 1≤S,E≤N, S≠E, 1≤K≤10000, 1≤T≤100000000 ).

Then M lines follows, each line containing three numbers U,V and W (1≤U,V≤N,1≤W≤1000) . It shows that there is a directed road from U-th spot to V-th spot with time W.

It is guaranteed that for any two spots there will be only one directed road from spot AA to spot BB (1≤A,B≤N,A≠B), but it is possible that both directed road <A,B><A,B> and directed road <B,A><B,A>exist.

All the test cases are generated randomly.

Output

One line containing a sentence. If it is possible for JOJO to arrive at the destination in time, output "yareyaredawa" (without quote), else output "Whitesnake!" (without quote).

样例输入

2 2
1 2 2 14
1 2 5
2 1 4

样例输出

yareyaredawa

题目来源

ACM-ICPC 2018 沈阳赛区网络预赛

题意

N个点,M条边,起始点为s,结束为n,求s到n的第k短的路的长度,判断长度是否大于T,如果大于,输出“Whitesnake!”,否则输出“yareyaredawa

这个题和POJ2449基本上一样,就多了一个和T的比较,找了模板改改就过了,点击查看模板链接。//注意输出的W是大写

AC代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <string>
#define ll long long
#define ull unsigned long long
#define ms(a) memset(a,0,sizeof(a))
#define pi acos(-1.0)
#define inf 0x7f7f7f7f
#define lson o<<1
#define rson o<<1|1
const double E=exp(1);
const int maxn=1e6+10;
const int mod=1e9+7;
using namespace std;
ll num1=0,num2=0,n,m,s,t,r,k,h1[maxn],h2[maxn],d[maxn],flag[maxn]; 
inline int read() 
{
    int X=0,w=1; 
    char c=getchar();
    while (c<'0'||c>'9') { if (c=='-') w=-1; c=getchar(); }
    while (c>='0'&&c<='9') X=(X<<3)+(X<<1)+c-'0',c=getchar();
    return X*w;
}
struct node1
{
	ll x,y,z,next;
}mp1[maxn],mp2[maxn];
struct node
{
    ll v,c;
    node(ll vv,ll cc) : v(vv),c(cc){}
    friend bool operator < (node x,node y){return x.c+d[x.v]>y.c+d[y.v];}
};
inline void insert1(ll x,ll y,ll z)
{
	mp1[++num1].x=x;
	mp1[num1].y=y;
	mp1[num1].z=z;
	mp1[num1].next=h1[x];
	h1[x]=num1;
}
inline void insert2(ll x,ll y,ll z)
{
	mp2[++num2].x=x;
	mp2[num2].y=y;
	mp2[num2].z=z;
	mp2[num2].next=h2[x];
	h2[x]=num2;
}
void spfa()
{
    queue<ll>Q;
    Q.push(t);
    for(int i=1;i<=n;i++) 
    	d[i]=inf;
    d[t]=0;
    ms(flag);
    flag[t]=1;
    while(!Q.empty())
    {
        ll u=Q.front();
        Q.pop();
        flag[u]=0;
        for(int i=h1[u];i;i=mp1[i].next)
        {
            ll v=mp1[i].y;
            if(d[v]>d[u]+mp1[i].z)
            {
                d[v]=d[u]+mp1[i].z;
                if(!flag[v])
                {
                    flag[v]=1;
                    Q.push(v);
                }
            }
        }
    }
}
ll astar(){
    if(d[s]==inf) 
    	return -1;
    priority_queue<node>p;
    ll cnt=0;p.push(node(s,0));
    while(!p.empty())
    {
        node u=p.top();p.pop();
        if(u.v==t)
        {
            cnt++;
            if(cnt==k) return u.c;
        }
        for(int i=h2[u.v];i;i=mp2[i].next)
        {
            ll y=mp2[i].y;
            p.push(node(y,u.c+mp2[i].z));
        }
    }
    return -1;
}
int main(int argc, char const *argv[])
{
	while(~scanf("%lld%lld",&n,&m))
	{
		s=read();t=read();k=read();r=read();
		ms(h1);
		num1=0;
		ms(h2);
		num2=0;
		while(m--)
		{
			ll x,y,z;
			x=read();y=read();z=read();
			insert1(y,x,z);insert2(x,y,z); 
		}
		spfa();
        ll _=astar();
        if(_==-1||_>r)
        	printf("Whitesnake!\n");
        else
        	printf("yareyaredawa\n");
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值