2017杭电多校联赛-KazaQ's Socks 找规律

KazaQ's Socks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2375    Accepted Submission(s): 1074


Problem Description
KazaQ wears socks everyday.

At the beginning, he has  n  pairs of socks numbered from  1  to  n  in his closets. 

Every morning, he puts on a pair of socks which has the smallest number in the closets. 

Every evening, he puts this pair of socks in the basket. If there are  n1  pairs of socks in the basket now, lazy  KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the  k -th day.
 

Input
The input consists of multiple test cases. (about  2000 )

For each case, there is a line contains two numbers  n,k   (2n109,1k1018) .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where  x  indicates the case number starting from  1  and  y  denotes the answer of corresponding case.
 

Sample Input
  
  
3 7 3 6 4 9
 

Sample Output
  
  
Case #1: 3 Case #2: 1 Case #3: 2
题目大意:有n双袜子,每天穿一双然后把昨天的袜子放在篮子里,当篮子里有n-1双袜子的时候就要去洗了,不然明天没有袜子穿,现在问第m天穿第几双袜子
直接找规律就可以了,可以先列出4双袜子的全部天数 ,分析天数就可以得到规律:
代码如下:
#include <stdio.h>
using namespace std;
#define ll long long

int main()
{
	int n, ca=0; 
	ll k;
	while(~scanf("%d%lld", &n, &k)){
		if(k <= n) printf("Case #%d: %lld\n", ++ca, k);
		else{
			k -= n;
			ll t = k / (n - 1);
			k %= n - 1;
			if(!k) printf("Case #%d: %d\n", ++ca, t & 1 ? n - 1 : n);
			else printf("Case #%d: %lld\n", ++ca, k);
		}
	}
  return 0;
}

题目链接:点击打开链接http://acm.hdu.edu.cn/contests/contest_showproblem.php?pid=1011&cid=759
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值