2017杭电多校联赛-Function

Function

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1594    Accepted Submission(s): 302


Problem Description
You are given a permutation  a  from  0  to  n1  and a permutation  b  from  0  to  m1 .

Define that the domain of function  f  is the set of integers from  0  to  n1 , and the range of it is the set of integers from  0  to  m1 .

Please calculate the quantity of different functions  f  satisfying that  f(i)=bf(ai)  for each  i  from  0  to  n1 .

Two functions are different if and only if there exists at least one integer from  0  to  n1  mapped into different integers in these two functions.

The answer may be too large, so please output it in modulo  109+7 .
 

Input
The input contains multiple test cases.

For each case:

The first line contains two numbers  n,   m (1n100000,1m100000)

The second line contains  n  numbers, ranged from  0  to  n1 , the  i -th number of which represents  ai1 .

The third line contains  m  numbers, ranged from  0  to  m1 , the  i -th number of which represents  bi1 .

It is guaranteed that  n106,   m106 .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where  x  indicates the case number starting from  1  and  y  denotes the answer of corresponding case.
 

Sample Input
  
  
3 2 1 0 2 0 1 3 4 2 0 1 0 2 3 1
 

Sample Output
  
  
Case #1: 4 Case #2: 4
题目大意:给你一些个关系式f(i)=bf(a(i)),询问满足这个关系式有多少种可能。
解题思路:
其实这道题可以转化为求环的问题,有多少种方式可以构成题目要求的环,即b的环可以有多少种方式画成a的环
来看第一个样例:
a:1 , 0 , 2
b:0 , 1
则a0->a1->a0, a2->a2
b0->b0, b1->b0
则,由图可以得到a的第一环可以由b的两种方式构成,a的第二个环可以由b的两种方式构成,则由b构成a总共有2*2=4种方式。
让我们看第二个样例:
a:2 , 0 , 1
b: 0 , 2 , 3 , 1
则a:a0->a2->a1->a0
b: b0->b0 b1->b2->b3->b1
即:
如图,a只有一种环,所以b只需要构成这一种环就行了,有4种方式可以构成这个环。
所以题目转换为求构成环的方式了。
ac代码:
#include <bits/stdc++.h>
using namespace std;
#define ll long long
#define pb push_back
#define mkp make_pair
#define ite iterator
#define fi first
#define se second
#define FOR(i, l, r) for(int i = l; i <= r; i++)
#define ROF(i, r, l) for(int i = r; i >= l; i--)
#define M 1000000007

const int maxn = 100100;
int n, m, cal[2][maxn], a[maxn], b[maxn], ans = 1;
bool vis[maxn];

void dfs(int t, int l, int *a, int k){
	if(vis[t]){
		cal[k][l]++;
		return;
	}
	vis[t] = 1;
	dfs(a[t], l + 1, a, k);
}

int main(){
    int ca = 0;
	while(~scanf("%d%d", &n, &m)){
		for(int i = 0; i < n; i++)
			scanf("%d", a + i);
		for(int i = 0; i < m; i++)
			scanf("%d", b + i);
		memset(cal, 0, sizeof(cal));
		memset(vis, 0, sizeof(vis));
		for(int i = 0; i < m; i++)
			if (!vis[i]) dfs(i, 0, b, 0);
		memset(vis, 0, sizeof(vis));
		for(int i = 0; i < n; i++)
			if (!vis[i]) dfs(i, 0, a, 1);
		ans = 1;
		for(int i = 1; i <= n; i++)
			if(cal[1][i]){
				int lim = (int)sqrt(i + 0.5), ta = 0;
				for(int j = 1; j <= lim; j++)
					if(i % j == 0){
						(ta += (ll)cal[0][j] % M * j % M) %= M;
						if (j * j != i) (ta += (ll)cal[0][i / j] % M * (i / j) % M) %= M;
					}
				for(int j = 1; j <= cal[1][i]; j++)
					ans = (ll)ans * ta % M;
			}
		printf("Case #%d: %d\n", ++ca, ans);
	}
  return 0;
}



  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值