Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 94 Accepted Submission(s) : 22
Problem Description Given a positive integer N, you should output the most right digit of N^N.
Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output For each test case, you should output the rightmost digit of N^N.
Sample Input2
3
4
Sample Output7
6
[hint]
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
[/hint] `这道题需要用到快速幂去求解,N可能过大所以用long long保险
#include<stdio.h>
long long quickpow(long long a,long long b,long long c)
{
int ans=1;
a=a%c;
while(b>0)
{
if(b%2==1)
ans=(ans*a)%c;
b=b/2;
a=(a*a)%c;
}
return ans;
}
int main()
{
long long t,n,m;
scanf("%lld",&t);
while(t--)
{
scanf("%lld",&n);
printf("%lld\n",quickpow(n,n,10));
}
return 0;
}