hdu 1394(求逆序数)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16401    Accepted Submission(s): 9975


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

#include<stdio.h>
#include<string.h>
struct tree
{
    int l,r,n;
} s[5000010];
void in(int i,int l,int r)
{
    s[i].l=l;
    s[i].r=r;
    s[i].n=0;
    if(l==r)
        return ;
    int mid=(l+r)/2;
    in(i*2,l,mid);
    in(i*2+1,mid+1,r);
}
void _insert(int i,int m)
{
    if(s[i].l==m&&s[i].r==m)
    {
        s[i].n=1;
        return ;
    }

    int mid=(s[i].l+s[i].r)/2;
    if(m<=mid)
    {
        _insert(i*2,m);
    }
    else
    {
        _insert(i*2+1,m);
    }
    s[i].n=s[i*2].n+s[i*2+1].n;
}
int _add(int i,int l,int r)
{
    if(s[i].l==l&&s[i].r==r)
    {
        return s[i].n;
    }
    int mid=(s[i].l+s[i].r)/2;
    if(l<=mid)
    {
        if(r<=mid)
            return _add(i*2,l,r);
        else
            return _add(i*2,l,mid)+_add(i*2+1,mid+1,r);
    }
    else
        return _add(i*2+1,l,r);
}
int main()
{
    int n,a[5010];
    while(~scanf("%d",&n))
    {
        in(1,0,n-1);
        int sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]+1<n)
            {
                sum+=_add(1,a[i]+1,n-1);
            }
            _insert(1,a[i]);
        }
        int min=sum;
        for(int i=0; i<n; i++)
        {
            sum=sum+n-1-2*a[i];  //当a[i]由第一个变为最后一个时,要加上a[i]后面大于a[i]的数的个数,有n-1-a[i]个,要
            if(min>sum)              //减去a[i]后面小于a[i]的数的个数,有a[i]个(注意i是从0开始的)
                min=sum;
        }
        printf("%d\n",min);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值