Hay For Sale(c++)

约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草. 顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(1≤Vi≤C).约翰只能整包购买,

他最多可以运回多少体积的干草呢?

Input

Line 1: Two space-separated integers: C and H

Lines 2..H+1: Each line describes the volume of a single bale: V_i

Output

Line 1: A single integer which is the greatest volume of hay FJ can purchase given the list of bales for sale and constraints.

Sample Input

7 3
2
6
5

Sample Output

7

Hint

The wagon holds 7 volumetric units; three bales are offered for sale with volumes of 2, 6, and 5 units, respectively.

Buying the two smaller bales fills the wagon.

 

AC代码

#include<bits/stdc++.h>
using namespace std;
int main(){
	int c,h;
	cin>>c>>h;
	int a[5001],f[50001];	
	for(int i=0;i<h;++i)
		cin>>a[i];
	memset(f,0,sizeof(f));
    for(int i=0;i<h;i++)
        for(int j=c;j>=a[i];j--)
            f[j]=max(f[j],f[j-a[i]]+a[i]);
    cout<<f[c];                                                	
	return 0;
}

一维动态规划解决01背包问题。

注:按照课本代码,即设置重量和价值一致,建立二维数组f[][],得出的数值正确,但无法AC。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值