Min Number

J - Min Number
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029





#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[10000000],b[10000000];
int main()
{
    int t,l,i,j;
    scanf("%d",&t);
    while(t--)
    {
        int m;
        scanf("%s%d",a,&m);
        l=strlen(a);
        if(m==0)
        {
            printf("%s\n",a);
        }
        else
        {
            for(i=0; i<l; i++)
            {
                b[i]=a[i];
            }
            sort(b,b+l);//排序
            int h=0;
            char we=a[0];
            for(i=0; i<l; i++)//把第一个数的大小先排好
            {
                if(b[i]!='0')
                {
                    if(a[0]>b[i]&&b[i]!=-1)
                    {
                        for(j=0; j<l; j++)
                        {
                            if(a[j]==b[i])//找到原来的b[i]的位置
                            {
                                b[i]=-1;
                                int f;
                                f=j;
                                int s;
                                s=a[0];//交换
                                a[0]=a[f];
                                a[f]=s;
                                m--;
                            }
                        }
                    }
                    else if(a[0]==b[i]&&b[i]!=-1)
                    {
                        h++;
                        b[i]=-1;
                        if(h>1)
                        {
                            //printf("&&&%d\n",h);
                            for(int v=1; v<h; v++)
                            {
                                b[i]=we;
                                //printf("%c %c %d\n",b[i],we,i);
                            }
                        }
                        else
                        {
                            b[i]=-1;
                        }
                    }
                }
            }
            int p=1;//从后一个开始排
            int q,w;
            for(j=0; j<l; j++)
            {
                if(a[p]>b[j]&&b[j]!=-1)
                {
                    for(int k=p+1; k<l; k++)//注意此句,从p的后一个开始找b[j]原来的位置
                    {
                        if(a[k]==b[j])//找到之后记住下标,然后交换位置
                        {
                            b[j]=-1;
                            int r;
                            r=k;
                            int q;
                            q=a[p];
                            a[p]=a[r];
                            a[r]=q;
                            m--;
                            p++;
                            if(m<=0||p>=l)
                            {
                                break;
                            }
                        }
                    }
                }
                if(a[p]<=b[j]&&b[j]!=-1)
                {
                    b[j]=-1;
                    p++;
                    if(p>=l||m<=0)
                    {
                        break;
                    }
                }
            }
            for(i=0; i<l; i++)
            {
                printf("%c",a[i]);
            }
            printf("\n");
        }
    }
}

 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值