ztr loves math

ztr loves math

Accepts: 303
Submissions: 1975
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description

ztr loves research Math.One day,He thought about the "Lower Edition" of triangle equation set.Such as n=x2−y2n=x^{2}-y^{2}n=x2y2.

He wanted to know that ,for a given number n,is there a positive integer solutions?

Input

There are T test cases. The first line of input contains an positive integer T(T<=106)T(T<=10^{6})T(T<=106) indicating the number of test cases.

For each test case:each line contains a positive integer ,n<=1018n <=10^{18}n<=1018.

Output

If there be a positive integer solutions,print TrueTrueTrue,else print FalseFalseFalse

Sample Input
4
6
25
81
105
Sample Output
False
True
True
True


    
    
Hint
For the fourth case, 105=132−82105 = 13^{2}-8^{2}105=13282
#include<stdio.h>
#include<math.h>
int main()
{
    int t,i,j;
    long long int n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        int p=1;
         if(n==1||n==2||n==4)
         {
             p=0;
         }
         if(n>6)
         {
             if(n%4==0)
             {
                 p=0;
             }
         }
         if(p)
         {
             printf("True\n");
         }
         else
         {
             printf("False\n");
         }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值