River Hopscotch

River Hopscotch
Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:数轴上有n个石子(但一共有n+2个,因为开头和结尾各有一个记为0,n+1),第i个石头的坐标为Di,现在要从0跳到L,每次条都从一个石子跳到相邻的下一个石子。现在FJ允许你移走M个石子,问移走这M个石子后,相邻两个石子距离的最小值的最大值是多少,因为移动有很多种方法,每一种有一个最小值距离,这些最小值里面的最大值。

思路:二分距离,当你已经模拟了一个距离值后,需要对原有的石子进行移动,因为你模拟的最小间距,所以如果两个相邻石子距离比他小,那么就应该移除后一个石子,记录移除石子+1,然后进行下次计算,直到有个点和开始的这个点距离大于最小值(开始的点不一定是起点),记得此时更改起始点为满足时的后一个点,进行下次比较,最后比较移除的石子和实际的比较,再改变高低点的位置。

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[60000];
int n,l,m,mid;
int ha(int mid)
{
    int p=0;
    int k=0;
    for(int i=1; i<=n; i++)
    {
        if((a[i]-a[k])<mid)
        {
            p++;
        }
        else
        {
             k=i;
        }
    }
    if(l-a[k]<mid)
        return 0;
    else if(p>m)
        return 0;
    return 1;
}
int main()
{

    while(scanf("%d%d%d",&l,&n,&m)!=-1)
    {
         a[0]=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n+1);
        int we=0;
        int ni=l;
        int g;
        while(we<=ni)
        {
            mid=(we+ni)/2;
           if(ha(mid))//如果已经满足移走的步数,你需要找个大一点的数,把当前的最小步数+1变成二分的最左边,在进行二分
            {
                we=mid+1;
                 g=mid;
            }
            else
            {
                ni=mid-1;//如果不满足移走的步数,或l-a[k]>mid,说明你假设的那个中间值mid太大了,你需要把它变小一点,就把mid-1当成最右边,再进行二分
            }
        }
        printf("%d\n",g);

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值