相交圆面积

Hard problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5    Accepted Submission(s): 5


Problem Description
cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?


Give you the side length of the square L, you need to calculate the shaded area in the picture.

The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.
 

Input
The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).
 

Output
For each test case, print one line, the shade area in the picture. The answer is round to two digit.
 

Sample Input
  
  
1 1
 

Sample Output
  
  
0.29
模板题:套用相交圆面积模板(左上半径为l的园,和里面的圆相交的面积。。。还有还要计算右下半部分半径为l的圆和里面的圆相交的面积(不过相交的面积都一样))
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define esp 1e-8
using namespace std;
#define p 3.14159265358979323846
double we(double c1, double c2,double l)
{
    double d;
    double s,s1,s2,s3,angle1,angle2,temp;
    d=(l*(double)sqrt(2))/2.0;
    if(d>=(c1+c2))//两圆相离
        return 0;
    if((c1-c2)>=d)//两圆内含,c1大
        return acos(-1.0)*c2*c2;
    if((c2-c1)>=d)//两圆内含,c2大
        return acos(-1.0)*c1*c1;
    angle1=acos((c1*c1+d*d-c2*c2)/(2*c1*d));
    angle2=acos((c2*c2+d*d-c1*c1)/(2*c2*d));
    s1=angle1*c1*c1;
    s2=angle2*c2*c2;
    s3=c1*d*sin(angle1);
    s=s1+s2-s3;
    return s;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double l;
        scanf("%lf",&l);
        double ha,haha;
        if(we(l,l/2.0,l))
        {
        ha=we(l,l/2.0,l);
        haha=ha;
        double sum,ni;
        sum=p*(l/2.0)*(l/2.0);
        ni=2.0*ha-sum;
        printf("%.2lf\n",sum-ni);
        }
        else
        {
            printf("0\n");
        }

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值