Coco

1058 - Coco

Time Limit:1s Memory Limit:64MByte

Submissions:282Solved:135

DESCRIPTION

Coco just learned a math operation call mod.Now,there is an integer aa and nn integers b1,,bnb1,…,bn. After selecting some numbers from b1,,bnb1,…,bn in any order, say c1,,crc1,…,cr, Coco want to make sure that amodc1modc2modmodcr=0amodc1modc2mod…modcr=0\ (i.e., aa will become the remainder divided by cici each time, and at the end, Coco want aa to become 00). Please determine the minimum value of rr. If the goal cannot be achieved, print 1−1 instead.

INPUT
The first line contains one integer T(T5)T(T≤5), which represents the number of testcases. For each testcase, there are two lines:1. The first line contains two integers nn and aa\ ( 1n20,1a1061≤n≤20,1≤a≤106).2. The second line contains nn integers b1,,bnb1,…,bn\ ( 1in,1bi106∀1≤i≤n,1≤bi≤106).
OUTPUT
Print TT answers in TT lines.
SAMPLE INPUT
2
2 9
2 7
2 9
6 7
SAMPLE OUTPUT
2
-1
题意:给一个数k和其他n个数,问能否从n个数中任选几个数使k模这几个数之后结果为0。若能则输出最少选的数字个数,不能输出-1。
思路:直接从大到小排序,然后比k大的数直接跳过,比k小的数每次递归模,中间只要模到结果为0就结束,并更新最小值
#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
#include<math.h>
using namespace std;
int ans;
int a[30],f,n;
bool cmp(int a,int b){
    return a>b;
}
int we(int a1,int s,int step){
    if(a1==0){
        ans=ans>step?step:ans;
        return 1;
    }
    int i;
    for(i=s;i<n;i++){
        if(a[i]<=a1)
        {
            f=i;
            break;
        }
    }
    if(i==n)
        return 0;
    for(i=f;i<n;i++){
        return we(a1%a[i],i+1,++step);
    }
}
int main(){
    int t;
    int a1;
    cin>>t;
    while(t--){
        cin>>n>>a1;
        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        ans=10000000;
        sort(a,a+n,cmp);
        if(we(a1,0,0))
            cout<<ans<<endl;
        else
        	cout<<-1<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值