Description
Input
Output
Sample Input
Sample Output
Hint
Description
Polar bears Menshykov and Uslada from the zoo of St. Petersburg and elephant Horace from the zoo of Kiev got hold of lots of wooden cubes somewhere. They started making cube towers by placing the cubes one on top of the other. They defined multiple towers standing in a line as a wall. A wall can consist of towers of different heights.
Horace was the first to finish making his wall. He called his wall an elephant. The wall consists ofw towers. The bears also finished making their wall but they didn't give it a name. Their wall consists ofn towers. Horace looked at the bears' tower and wondered: in how many parts of the wall can he "see an elephant"? He can "see an elephant" on a segment ofw contiguous towers if the heights of the towers on the segment match as a sequence the heights of the towers in Horace's wall. In order to see as many elephants as possible, Horace can raise and lower his wall. He even can lower the wall below the ground level (see the pictures to the samples for clarification).
Your task is to count the number of segments where Horace can "see an elephant".
Input
The first line contains two integers n andw (1 ≤ n, w ≤ 2·105) — the number of towers in the bears' and the elephant's walls correspondingly. The second line contains n integers ai (1 ≤ ai ≤ 109) — the heights of the towers in the bears' wall. The third line contains w integers bi (1 ≤ bi ≤ 109) — the heights of the towers in the elephant's wall.
Output
Print the number of segments in the bears' wall where Horace can "see an elephant".
Sample Input
13 5 2 4 5 5 4 3 2 2 2 3 3 2 1 3 4 4 3 2
2
Sample Output
Hint
The picture to the left shows Horace's wall from the sample, the picture to the right shows the bears' wall. The segments where Horace can "see an elephant" are in gray.
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<ctype.h>
#include<math.h>
#include<algorithm>
#include<time.h>
using namespace std;
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
const int N=2e5+10,M=0,Z=1e9+7,ms63=1061109567;
int n,m;
int w[N],a[N],b[N];
int we[N];
void next()
{
int j=0;we[1]=0;
for(int i=2;i<=m;++i)
{
while(j&&b[j+1]!=b[i])j=we[j];
if(b[j+1]==b[i])++j;
we[i]=j;
}
}
void kmp()
{
int ans=0;
int j=0;
for(int i=1;i<=n;++i)
{
while(j&&b[j+1]!=a[i])j=we[j];
if(b[j+1]==a[i])++j;
if(j==m)++ans;
}
printf("%d\n",ans);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=1;i<=n;++i)scanf("%d",w[i]);
for(int i=1;i<n;++i)a[i]=w[i]-w[i+1];
for(int i=1;i<=m;++i)scanf("%d",&w[i]);
for(int i=1;i<m;++i)b[i]=w[i]-w[i+1];
if(m==0)
{
printf("%d\n",n+1);
continue;
}
next();
kmp();
}
return 0;
}