Boolean Expressions

The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next:         

 
 
Expression: ( V | V ) & F & ( F | V )
where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed. To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file. Input
The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown. The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below.
Output
For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line. Use the same format as that shown in the sample output shown below.
Sample Input
( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))
Sample Output
Expression 1: F
Expression 2: V
Expression 3: V

 
 
分析:表达式求值,中缀转后缀再求值;
   当前操作符是(时,直接入栈;)时,一直出栈到(结束;!时,直接进栈,待进数时,直接出栈;其余按优先级来即可;

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
using namespace std;
int we(char a)
{
    switch(a)
    {
    case '|':
       return 1;
       break;
    case '&' :
        return 2;
        break;
    case '!' :
        return 3;
        break;
    case '(' :
        return 0;
        break;
    default :
        return -1;
    }
}
int main()
{
    int i,j,k,n,t,top,p;
    scanf("%d",&n);
   char s11[10000];
   int g=0;
    while(gets(s11))
    {
        ++g;
        int f=0,k=0;
        char s[150];
        char s2[1000+10],s3[1000+10],s1[10000];
        int s4[10010];
        memset(s4,0,sizeof(s4));
        t=strlen(s11);
        int j=-1,top=0,p1=0;
        for(int i=0;i<t;i++)
        {
            if(s11[i]=='F')
            {
                s1[p1++]='0';
            }
            if(s11[i]=='V')
            {
                s1[p1++]='1';
            }
            if(s11[i]=='|'||s11[i]=='!'||s11[i]=='&'||s11[i]=='('||s11[i]==')')
                s1[p1++]=s11[i];
            else
                continue;
        }
        //cout<<s1;
        for(i=0; i<p1; i++)
        {
            if(s1[i]=='0'||s1[i]=='1')
            {
                s3[++j]=s1[i];
            }
            else if(s1[i]=='(')
            {
                s3[++j]=' ';
                s2[++top]=s1[i];
            }
            else if(s1[i]==')')
            {
                while(s2[top]!='(')
                {
                    s3[++j]=' ';
                    s3[++j]=s2[top];
                    --top;
                }
                s3[++j]=' ';
                --top;
            }
            else if(s1[i]=='!'||s1[i]=='|'||s1[i]=='&')
            {
                if(s1[i]=='!')//这个!单独写
                {
                    s2[++top]=s1[i];
                }
                else
                {
                while(we(s1[i])<=we(s2[top]))
                {
                    s3[++j]=' ';
                    s3[++j]=s2[top];
                    --top;
                }
                s3[++j]=' ';
                s2[++top]=s1[i];
                }
            }
        }
        while(top>=1)
        {
            s3[++j]=' ';
            s3[++j]=s2[top];
            --top;
            if(s2[1]=='(')
                break;
        }
        s3[++j]=' ';
        //s3[++j]='\0';
//        for(int i=0;i<j;i++)
//        {
//            if(s3[i]!=' ')
//                printf("%c",s3[i]);
//        }
        int p=0;
        k=0;
        for(int i=0; i<j; i++)
        {
            if(s3[i]=='1'||s3[i]=='0')
            {
                s4[p++]=s3[i]-'0';
            }
            else if(s3[i]==' ') continue;
            else if(s3[i]=='!'||s3[i]=='&'||s3[i]=='|')
            {
                int ni,ha;
                p=p-1;
                ni=s4[p];
                if(s3[i]=='&')
                {
                    ha=s4[--p];
                    s4[p++]=(ni&ha);
                }
                if(s3[i]=='|')
                {ha=s4[--p];
                    s4[p++]=(ni|ha);
                }
                if(s3[i]=='!')
                {
                s4[p++]=(!ni);
                }
            }
        }
        printf("Expression %d: ",g);
        if(s4[p-1]==0)
        {
            printf("F\n");
        }
        else
            printf("V\n");
    }
    return 0;
}
测试样例:
F &!F |  !V|!V  & !F& !(  F | F& (V |  !F| !V| V& (V|F)))
F& !F|!V|!F&  (V|F| !V) & !F&!(F|F& (V | !F|!V|  V &(V| F)  ))
F&!F  | !V| !F&  !!!(  V|F| !V) & !F&!(F|F&  (V|!F|!V|V&(V|F)))
!V|!F&! (V|(F | V )| !V)& !F& !!(F| F& (V|!F|!V|V&(  V| F )))
(F|(F&V)|!V)&!F&! (F|(F&( V| !F|!V |V& (V |F)) ))
V
(((V)))
((!(F)))
(!(!(   !(F ))))
!!F|!F&!(V|(F|V)|!V)&!F&!!(F|F&(V|!F|!V|V&(V|F)))|((!(F)))
Expression 1: F
Expression 2: V
Expression 3: F
Expression 4: F
Expression 5: F
Expression 6: V
Expression 7: V
Expression 8: V
Expression 9: V
Expression 10: V






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值