SPY

The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’s confidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?

A:the list contains that will come to the NationX’s frontier.

B:the list contains spies that will be sent by Nation Y.

C:the list contains spies that were sent to NationY before.

Input
There are several test cases.
Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.
The second part contains A strings, the name list of that will come into the frontier.
The second part contains B strings, the name list of that are sent by NationY.
The second part contains C strings, the name list of the “dual_spy”.
There will be a blank line after each test case.
There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.
Output
Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.
Sample Input
8 4 3
Zhao Qian Sun Li Zhou Wu Zheng Wang
Zhao Qian Sun Li
Zhao Zhou Zheng
2 2 2
Zhao Qian
Zhao Qian
Zhao Qian
Sample Output

Qian Sun Li

No enemy spy

题意:输入n,m,k三个数,第二行有n个名字代表即将进入we国的人,第三行有m个名字代表ni国派往we的间谍的名字(里面有可能有we国家派往ni国的间谍,也被ni国派过去了),第四行有k个名字代表we国家派往ni国家间谍的名字。现在we国家想要抓出真正的间谍。。注意格式,最后一个没有空格

思路:用map,比较好解决

#include<stdio.h>
#include <iostream>
#include<string.h>
#include<string>
#include<cstring>
#include<vector>
#include<map>
using namespace std;
string s1[100],s2[100],s3[100],s4[10000];
int main()
{
    int a,b,c;
    while(scanf("%d%d%d",&a,&b,&c)!=-1)
    {
        map<string,int>we;
        map<string,int>ni;
        for(int i=0; i<a; i++)
        {
            cin>>s1[i];
            we[s1[i]]++;
        }
        for(int i=0; i<b; i++)
        {
            cin>>s2[i];
            we[s2[i]]++;
        }
        for(int i=0; i<c; i++)
        {
            cin>>s3[i];
            ni[s3[i]]++;
        }
        int j=0;
        for(int i=0; i<a; i++)
        {
            if(we[s1[i]]==2&&!ni[s1[i]])
            {
                s4[j++]=s1[i];
            }
        }
        if(j==0)
            printf("No enemy spy\n");
        else
        {
            for(int i=0; i<j; i++)
            {
                 if(i<j-1)cout<<s4[i]<<" ";
                  else cout<<s4[i]<<endl;
            }
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值