hdu1312 深搜 java

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
….#.
…..#
……
……
……
……
……

@…

.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

import java.util.Scanner;


public class P1312 {
    private static int dir[][]={{-1,0},{1,0},{0,-1},{0,1}};//上下左右
    static long max=-1;
    static long num=0;
    static int h,w;
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){
            w=sc.nextInt();
            h=sc.nextInt();
            if(w==0&&h==0){
                return;
            }
            char arr[][]=new char[h][w];
            int x = 0,y=0;
            int vistied[][]=new int[h][w];
            for(int i=0;i<arr.length;i++){
                String str=sc.next();
                for(int j=0;j<arr[i].length;j++){
                    arr[i][j]=str.charAt(j);
                    vistied[i][j]=0;
                    if(arr[i][j]=='@'){
                        x=i;
                        y=j;
                    }
                }
            }
            num=1;
            dfs(arr, x, y,vistied);
            System.out.println(num);
        }

    }


    private static void dfs(char[][] arr,int a ,int b,int[][] vistied) {
        for(int i=0;i<dir.length;i++){
            int x=dir[i][0]+a;
            int y=dir[i][1]+b;
            if(inmap(x,y)&&arr[x][y]=='.'&&vistied[x][y]==0){
                num++;
                vistied[x][y]=1;
                dfs(arr, x, y, vistied);
            }
        }
    }


    private static boolean inmap(int a, int b) {
        if(a<0 || b<0 || a>=h || b>=w){
                return false;
            }
            return true;
    }

}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值