POJ3262 Protecting the Flowers(贪心的水题)
Protecting the Flowers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3575 Accepted: 1465
Description
Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.
Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.
Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.
Input
Line 1: A single integer N
Lines 2… N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow’s characteristics
Output
Line 1: A single integer that is the minimum number of destroyed flowers
Sample Input
6
3 1
2 5
2 3
3 2
4 1
1 6
Sample Output
86
Hint
FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.
翻译:
FJ按以下顺序返回奶牛:6,2,3,4,1,5。当他把第6头牛运到谷仓时,其他人毁掉了24朵花;接下来他将带走第2头牛,失去28朵美丽的花草。对于3、4、1头奶牛,他分别损失了16、12和6朵花。当他挑选第五头牛时,再也没有牛破坏花了,所以那头牛的损失是零。以这种方式损失的花朵总数是24+28+16+12+6=86。
题目思路:
题目:主要看这个提示(HInt)的内容,其实推一下就出来了。
思路:就是看时间和吃花数量的比例,越小先计算,结算结果累加就好了。(提示要用long long,刚开始用的是int存,应该是存不下数据,答案错误)
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
#define ll __int64
ll sum[100010];
struct node{
int t,d;
}a[100000+10];
bool cmp(node x,node y){
return (x.t*1.0)/x.d<(y.t*1.0)/y.d;
}
int main(int argc, char** argv) {
memset(a,0,sizeof(a));
int n;
while(~scanf("%d",&n)){
ll sum=0;
for(int i=1;i<=n;i++){
cin>>a[i].t>>a[i].d;
sum=sum+a[i].d;
}
sort(a+1,a+1+n,cmp);
ll ans=0;
for(int i=1;i<n;i++){
sum=sum-a[i].d;
ans+=sum*a[i].t*2;
}
printf("%I64d\n",ans);
}
return 0;
}