HDU 1312

Red and Black
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10683    Accepted Submission(s): 6694

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.'.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 


Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 
Sample Output
45
59
6
13


//题意说的是从一个点出发最多能走多少步
//简单的深搜就可以解决了
#include<iostream>

#include<cstring>

using namespace std;

char map[22][22];
bool vis[22][22];
int row, col;

int sum;

void dfs(int i, int j)
{
    if (i >=1 && i <= row && j >=1 && j <= col)
    {
        sum++;
        vis[i][j] = 1;
        map[i][j] = '#';
        if (!vis[i+1][j] && map[i+1][j]=='.')
            dfs(i+1, j);
        if (!vis[i-1][j] && map[i-1][j]=='.')
            dfs(i-1, j);
        if (!vis[i][j+1] && map[i][j+1]=='.')
            dfs(i, j+1);
        if (!vis[i][j-1] && map[i][j-1]=='.')
            dfs(i, j-1);
    }
    return;
}
int main()
{
    int x, y, i, j;
    while (cin >> col >> row)
    {
        if (row == 0 && col ==0)
            break;
        sum = 0;
        memset(vis, 0, sizeof(vis));
        for (i = 1; i <= row; i++)
        {
            for (j = 1; j <= col; j++)
            {
                cin >> map[i][j];
                if (map[i][j] == '@')
                {
                    x = i;
                    y = j;
                }
            }
        }
        dfs(x, y);
        cout << sum << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值